[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] domU with two eth but only one is active

  • To: xen-users@xxxxxxxxxxxxx
  • From: SZABO Zsolt <szazs@xxxxxxxxx>
  • Date: Sat, 18 Jul 2015 11:37:06 +0200 (CEST)
  • Delivery-date: Sat, 18 Jul 2015 09:37:41 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

On Sat, 18 Jul 2015, SZABO Zsolt wrote:

Did you upgrade the guest too or just dom0?

I have also upgraded the guest to jessie...

Maybe I forgot something about the "history":
0. I had xen-4.1 on wheezy (dom0), and a squeeze domU
1. I upgraded domU to wheezy and later to jessie
   (the domU is the server of an LTSP clients on the local LTSP network
   i.e. eth1, and it worked; from outside I can access the domU through
   eth0 and it worked, too; however, the kernel was 3.2)
2. then I decided to upgrade the wheezy dom0 to jessie too
   and then upload the 3.16 kernel modules to the domU(s)
   (and modified the xl.pvexample script accordingly):

name = "linserver"
kernel = "/boot/vmlinuz-3.16.0-4-amd64"
ramdisk = "/boot/initrd.img-3.16.0-4-amd64"
extra = "root=/dev/xvda2 ro"

memory = 20480
vcpus = 16

vif  = [ 'mac=00:40:f6:54:79:0f,bridge=xenbr0',
         'mac=00:16:3e:00:02:01,bridge=xenbr1' ]

disk = [ '/dev/xcp/linsrv_7,raw,xvda2,rw',
on_poweroff = 'destroy'
on_reboot   = 'restart'
on_crash    = 'restart'

The mentioned other wheezy domU (acting as license server, see below)
runs also with kernel 3.16 (from the /boot of dom0)

Ok, I have another linux domU but with wheezy. Originally, only eth0 was configured, but now I have also tried to add eth1 similarly as to
the jessie domU and it works...

The dmesg of this domU is shorter:
# dmesg |grep net
[    0.004000] Initializing cgroup subsys net_cls
[    0.004000] Initializing cgroup subsys net_prio
[ 0.134434] microcode: Microcode Update Driver: v2.00 <tigran@xxxxxxxxxxxxxxxxxxxx>, Peter Oruba
[    0.134838] audit: initializing netlink subsys (disabled)
[    1.340978] xen_netfront: Initialising Xen virtual ethernet driver

Maybe the jessie upgrade missed some feature of the later upgraded dom0?
Or it is about some kind of other conflict...?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.