[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] GRUB2 randomly works on some hosts but not others?

On 09/11/2015 12:24 AM, Ian Campbell wrote:
> On Thu, 2015-09-10 at 19:25 +0000, Shaun Reitan wrote:
>> I'm starting to think this may be memory related.  I've tested this on a 
>> couple hosts with less than 32GB of RAM in them and grub2 seams to work 
>> on them.  Anything with 32 or more GB seams to fail... least so far.
> That's a pretty plausible sounding hypothesis.
> One way to confirm might be to boot one of the larger machines with
> "mem=32G" on the hypervisor's command line to restrict the host to 32G
> and see if grub suddenly starts working there or if the problem is at
> 32G or greater perhaps try 16G then 31G.

From our conversation yesterday it sounds like the problem came from one of the 
tools on centos 6 probably being too old. The build works after being
run on ubuntu trusty, which is what I originally used.

My guess is there may have been differences between CPU versions where more 
than 32GiB wasn't handled on newer xeons. A E5620 with less than 32GiB
worked, a E5645 with more than 32GiB ram failed, and a 5130 worked with more 
than 32GiB ram.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.