[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Issues installing Xen from source (was Re: )

Quoting Roger Pau Monné <roger.pau@xxxxxxxxxx>:

El 25/2/16 a les 13:38, Ayushi Arora ha escrit:

As asked of in the previous mail, I tried compiling Xen from source.
I am not sure whether we can ask questions for the task given, but I have
been stuck at it from yesterday.
I followed all the steps, and wherever there was some problem, I looked up
that in wiki of Xen, but after building and installing that with ovmf
enabled in ./configure, I moved on to the network configuration, and on
rebooting after the configuration, it is showing ' ERROR: Can't find
hypervisor information in sysfs!' on xm list and brctl shows no bridge
enabled. On further checking, it showed 'ERROR: Not running inside Xen'.
I have tried finding the problem, and I will check this again but I can't
move forward until the hypervisor runs!
Not sure where to check for the error.


I'm afraid you haven't provided enough information for us to even try to
guess what's going wrong. Also, if you are building Xen from source from
the official git repository (using the master or staging branches) you
shouldn't even have xm installed, it was removed quite some time ago.

Are you using grub in order to boot, in which case are you sure you have
the right entries in order to boot Xen and a Dom0 kernel?

Where's that xm cli coming from?

Have you setup a serial cable in order to debug all those issues?

Also, please remember to fill in the subject line with a proper
description of the issue next time. I've took the liberty of setting a
proper subject and moving the conversation to xen-users.


Xen-users mailing list

It sounds like you're not booting into Xen at all. The included grub script comes after 10_linux, so you'll have to choose the "Linux ..., with Xen hypervisor" option from the GRUB menu, within 5 seconds (default) of grub loading. You can also set that entry as the default if you don't like using the menu, see https://help.ubuntu.com/community/Grub2/Setup#Specific_Entries

Did you forget to run `grub-mkconfig -o /boot/grub/grub.cfg` or `update-grub` after installing Xen?

I had to tinker with the /etc/grub.d/ script included with the source to get it to work properly, but I don't remember exactly what I did. I think it wasn't picking up the kernel command line arguments correctly, but I doubt this is your problem since Linux boots fine. For reference, here's the one provided by Arch: https://aur.archlinux.org/cgit/aur.git/tree/09_xen?h=xen

ONLY AT VFEmail! - Use our Metadata Mitigator™ to keep your email out of the NSA's hands!
$24.95 ONETIME Lifetime accounts with Privacy Features!
No Bandwidth Quotas!   15GB disk space!
Commercial and Bulk Mail Options!

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.