[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Remus: No support for network buffering

Hello Ian
Thanks for your reply.
I installed libnl libraries, but then I started getting this error on many xen distributions (its the same error on xen 4.6 and 4.5) when I ran the same command as above:

sudo xl remus -Fd <domain_name> root@<backup_name>

libxl: error: libxl_exec.c:118:libxl_report_child_exitstatus: /etc/xen/scripts/remus-netbuf-setup setup [-1] exited with error status 1

libxl: error: libxl_netbuffer.c:360:netbuf_setup_script_cb: Cannot get ifb dev name for domain 4 dev vif4.0

libxl: error: libxl.c:885:libxl__remus_setup_done: Remus: failed to setup device for guest with domid 4, rc -3

Although it is working fine with network buffering disabled, as earlier.

My take on this is that there is some issue with setting up the qdisc on the backup. Am I right?
But I am not able to get solutions to this. Am I missing some packages, or scripts?
Can you please help out with this?



On Tue, Feb 23, 2016 at 4:56 AM, Ian Campbell <ian.campbell@xxxxxxxxxx> wrote:
On Sun, 2016-02-21 at 18:39 -0500, Harpreet Singh Chawla wrote:
> I have been trying to run remus on Xen 4.6
> I have successfully done basic migration to and fro from one server to
> another without any issues.
> But when I tried to run remus with networking enabled and disk buffering
> disabled,
> ```
> sudo xl remus -F -d linux-1 root@<server_domain_name>
> ```
> I get the following error message:
> ```
> migration target: Ready to receive domain.
> Saving to migration stream new xl format (info 0x3/0x0/1219)
> libxl: error: libxl.c:889:libxl__remus_setup: Remus: No support for
> network buffering
> Remus: Backup failed? resuming domain at primary.
> xc: error: Dom 1 not suspended: (shutdown 0, reason 255): Internal error
> libxl: error: libxl_dom_suspend.c:409:libxl__domain_resume:
> xc_domain_resume failed for domain 1: Invalid argument
> Loading new save file <incoming migration stream> (new xl fmt info
> 0x3/0x0/1219)
>  Savefile contains xl domain config in JSON format
> Parsing config from <saved>
> libxl: error: libxl_stream_read.c:298:stream_header_done: Invalid ident:
> expected 0x4c6962786c466d74, got 0x0000000000000000
> ```
> I don't really need disk buffering as of now, and in some prior thread of
> Migration Failure I read the feature doesn't work well in xen 4.6 (am not
> sure if it has been fixed), but I need network buffering.
> I can run the remus feature using the -n option for disabling network
> buffering, but not with with network buffering enabled.
> Anyone has a solution for fixing this?

You need to build the Xen tools with the libraries required for network
buffering available in the build environment. From README:
    * Development install of libnl3 (e.g., libnl-3-200,
      libnl-3-dev, etc).  Required if network buffering is desired
      when using Remus with libxl.  See docs/README.remus for detailed


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.