[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Remus: No support for network buffering

On Sat, Feb 27, 2016 at 01:05:57PM -0500, Harpreet Singh Chawla wrote:
> Hello Ian
> Thanks for your reply.
> I installed libnl libraries, but then I started getting this error on many
> xen distributions (its the same error on xen 4.6 and 4.5) when I ran the
> same command as above:
> sudo xl remus -Fd <domain_name> root@<backup_name>
> libxl: error: libxl_exec.c:118:libxl_report_child_exitstatus:
> /etc/xen/scripts/remus-netbuf-setup setup [-1] exited with error status 1

Make sure this script exists. Then you need to figure out why it fails,
probably with some debug output.

> libxl: error: libxl_netbuffer.c:360:netbuf_setup_script_cb: Cannot get ifb
> dev name for domain 4 dev vif4.0
> libxl: error: libxl.c:885:libxl__remus_setup_done: Remus: failed to setup
> device for guest with domid 4, rc -3
> Although it is working fine with network buffering disabled, as earlier.
> My take on this is that there is some issue with setting up the qdisc on
> the backup. Am I right?

I think the issue is in setting up netbuf.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.