[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Booting from Hard Disk [SOLVED]

  • To: Simon Jones <Simon@xxxxxxx>, "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>
  • From: Simon Jones <Simon@xxxxxxx>
  • Date: Fri, 8 Apr 2016 09:50:45 +0000
  • Accept-language: en-GB, en-US
  • Delivery-date: Fri, 08 Apr 2016 09:52:08 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>
  • Thread-index: AdGRe/mL8UZQmImoQb2KCJeYbUSvlQ==
  • Thread-topic: Booting from Hard Disk [SOLVED]

This turned out to be a firewall issue, the host system was restarted and 
loaded a default set of rules which were blocking communication with the 
terminal sessions, the vm's were actually booting but networking and console 
were blocked by the firewall!


-----Original Message-----
From: Xen-users [mailto:xen-users-bounces@xxxxxxxxxxxxx] On Behalf Of Simon 
Sent: 06 April 2016 13:04
To: xen-users@xxxxxxxxxxxxx
Subject: [Xen-users] Booting from Hard Disk

Hello,  I have been trying to resolve this issue for a number of days - so far 
without success.

I have 2 domains which won't start, both load the bios then stick at "Booting 
from hard disk" 

Both domains have been working perfectly for around 2 years, other domains 
using the same configuration boot fine.  Here is one of the config files;

name = 'server'
maxmem = 1024
memory = 1024
vcpus = 1
builder = 'hvm'
kernel = '/usr/lib/xen-4.0/boot/hvmloader'
hap = 1
disk = [ 
 ] #disk = [ 'phy:/dev/data1/ns03-disk,hda,w' ] boot = 'c'
#boot = 'd'
vif = [ 
 ] vnc = 1 vncdisplay = 6 vncpasswd = '********'
usb = 1
usbdevice = 'tablet'
on_poweroff = 'destroy'
on_reboot   = 'restart'
on_crash    = 'restart'

I can boot in to recovery mode to a debian iso and can access the partitions so 
the drives seem ok cm dmesg returns;

(XEN) HVM29: HVM Loader
(XEN) HVM29: Detected Xen v4.0.1
(XEN) HVM29: CPU speed is 2267 MHz
(XEN) irq.c:243: Dom29 PCI link 0 changed 0 -> 5
(XEN) HVM29: PCI-ISA link 0 routed to IRQ5
(XEN) irq.c:243: Dom29 PCI link 1 changed 0 -> 10
(XEN) HVM29: PCI-ISA link 1 routed to IRQ10
(XEN) irq.c:243: Dom29 PCI link 2 changed 0 -> 11
(XEN) HVM29: PCI-ISA link 2 routed to IRQ11
(XEN) irq.c:243: Dom29 PCI link 3 changed 0 -> 5
(XEN) HVM29: PCI-ISA link 3 routed to IRQ5
(XEN) HVM29: pci dev 01:2 INTD->IRQ5
(XEN) HVM29: pci dev 01:3 INTA->IRQ10
(XEN) HVM29: pci dev 03:0 INTA->IRQ5
(XEN) HVM29: pci dev 04:0 INTA->IRQ5
(XEN) HVM29: pci dev 05:0 INTA->IRQ10
(XEN) HVM29: pci dev 02:0 bar 10 size 02000000: f0000008
(XEN) HVM29: pci dev 03:0 bar 14 size 01000000: f2000008
(XEN) HVM29: pci dev 02:0 bar 14 size 00001000: f3000000
(XEN) HVM29: pci dev 03:0 bar 10 size 00000100: 0000c001
(XEN) HVM29: pci dev 04:0 bar 10 size 00000100: 0000c101
(XEN) HVM29: pci dev 04:0 bar 14 size 00000100: f3001000
(XEN) HVM29: pci dev 05:0 bar 10 size 00000100: 0000c201
(XEN) HVM29: pci dev 05:0 bar 14 size 00000100: f3001100
(XEN) HVM29: pci dev 01:2 bar 20 size 00000020: 0000c301
(XEN) HVM29: pci dev 01:1 bar 20 size 00000010: 0000c321
(XEN) HVM29: Multiprocessor initialisation:
(XEN) HVM29:  - CPU0 ... 40-bit phys ... fixed MTRRs ... var MTRRs [2/8] ... 
(XEN) HVM29: Writing SMBIOS tables ...
(XEN) HVM29: Loading ROMBIOS ...
(XEN) HVM29: 10588 bytes of ROMBIOS high-memory extensions:
(XEN) HVM29:   Relocating to 0xfc000000-0xfc00295c ... done
(XEN) HVM29: Creating MP tables ...
(XEN) HVM29: Loading Cirrus VGABIOS ...
(XEN) HVM29: Loading PCI Option ROM ...
(XEN) HVM29:  - Manufacturer: http://etherboot.org
(XEN) HVM29:  - Product name: gPXE
(XEN) HVM29: Loading ACPI ...
(XEN) HVM29:  - Lo data: 000ea020-000ea04f
(XEN) HVM29:  - Hi data: fc002c00-fc012d1f
(XEN) HVM29: vm86 TSS at fc013000
(XEN) HVM29: BIOS map:
(XEN) HVM29:  c0000-c8fff: VGA BIOS
(XEN) HVM29:  c9000-d57ff: Etherboot ROM
(XEN) HVM29:  eb000-eb140: SMBIOS tables
(XEN) HVM29:  f0000-fffff: Main BIOS
(XEN) HVM29: Invoking ROMBIOS ...
(XEN) HVM29: $Revision: 1.221 $ $Date: 2008/12/07 17:32:29 $
(XEN) stdvga.c:147:d29 entering stdvga and caching modes
(XEN) HVM29: VGABios $Id: vgabios.c,v 1.67 2008/01/27 09:44:12 vruppert Exp $
(XEN) HVM29: Bochs BIOS - build: 06/23/99
(XEN) HVM29: $Revision: 1.221 $ $Date: 2008/12/07 17:32:29 $
(XEN) HVM29: Options: apmbios pcibios eltorito PMM
(XEN) HVM29: 
(XEN) HVM29: ata0-0: PCHS=16383/16/63 translation=lba LCHS=1024/255/63
(XEN) HVM29: ata0 master: QEMU HARDDISK ATA-7 Hard-Disk (40960 MBytes)
(XEN) HVM29: IDE time out
(XEN) HVM29: ata1 master: QEMU DVD-ROM ATAPI-4 CD-Rom/DVD-Rom
(XEN) HVM29: IDE time out
(XEN) HVM29: 
(XEN) HVM29: 
(XEN) HVM29: 
(XEN) HVM29: Press F12 for boot menu.
(XEN) HVM29: 
(XEN) HVM29: Booting from Hard Disk...
(XEN) HVM29: Booting from 0000:7c00
(XEN) stdvga.c:151:d29 leaving stdvga

I haven't changed anything on the host system, or with the vm configuration and 
am running out of ideas what to try next.  Any help is appreciated, Thank you.


Xen-users mailing list
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.