[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Openindiana (was Mac OSX How-to)

On Friday, 12 August 2016, 18:50:40 EDT, PÁSZTOR György wrote:

> Hi,


> "jim burns" <jim_burn@xxxxxxxxxxxxx> írta 2016-08-12 09:50-kor:

> > So the state of the art is that you still can't run all your guests under

> > one virtualization product. Maybe what we need is a Type 0 hypervisor,

> > that makes all the Type 1 & 2 solutions play nice with each other :-) So

> > for now, I'm running Windows under Xen, OpenIndiana under straight Qemu,

> > w/ no acceleration (yes, it's slow), and I have to reboot to play with

> > OSX. I'm anxiously awaiting the next advance in technology!


> Why do you run OI in qemu instead of xen?


> Cheers,

> Gyu


I've been lurking around the xen-users list for many years, and fondly remember Boris Derzhavetz' posts about running OS under xen or virsh. I finally had the time to try it recently. By that time, OS became OpenIndiana. When I went back and looked at Boris' wordpress blogs, during the xen 3.x days, none of them worked anymore. So I started with the qemu command line that xen produced, stripped the xen socket stuff (qemu wouldn't run if xen wasn't actually in control), and played with options that xen doesn't let you specify, namely -cpu and -machine. I found that the Hipster development branch iso that I was working with was very sensitive to those options.


Many of the -cpu options either gave cpuid errors while booting, or even prevented the boot with "long jump" not supported errors. After settling on a few -cpu options that worked, I found that the -machine choices were critical. OI development, even in Hipster, lags linux by many years. They are still using Gnome 2 (which I actually prefer to 3), Xorg 1.14, and gcc 4.9. Fedora, for instance, uses Xorg 1.18, and gcc 6.1. OI boots just fine with the older "-machine pc" option, but will hang forever with the newer AHCI backed '-machine q35".


And Boris' approach to extract the xpv unix and boot_archive from the iso for the kernel= and ramdisk= xen pv options didn't work. Qemu would just immediately abort with no clues in the logs. And of course pygrub didn't work, because the legacy grub sources that xen uses don't understand the zfs filesystem. OS added that ability themselves.


That having been said, I would be more than grateful if you care to share a cfg file that works.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.