[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Problems installing Xen on Ubuntu

On Thu, Jan 19, 2017 at 2:20 PM, Victory Omole <vtomole@xxxxxxxxxxx> wrote:
It works on openSUSE, I have a question about Xen's design, This picture https://wiki.xenproject.org/wiki/File:XenArch1.png is kind of misleading. When i boot openSUSE (my dom0) with the hypervisor, does that mean openSUSE is running on top on the hypervisor as the drawing shows? Or does it mean that openSUSE is the bundled with the hypervisor? (which means dom0 should be in the same level as the hypervisor in the drawing). To be more clear, i booted up an OS in xen and it looks like the same thing that would happen if i used Qemu or VirtualBox. 

Thank you.

On Wed, Jan 18, 2017 at 11:19 AM, Victory Omole <vtomole@xxxxxxxxxxx> wrote:
Okay, i will try that, but i don't think that will make a difference, i tried it on Debian, same problem, It seems like a couple of people have had the same problem judging from the comments in this video:https://www.youtube.com/watch?v=fPUx8cE6ikI&t=829s. I also tried it on Gentoo and it just blinks with this https://postimg.org/image/z6hamyrcd/.  I'm trying Alpine Linux now.

On Tue, Jan 17, 2017 at 9:24 PM, WebDawg <webdawg@xxxxxxxxx> wrote:
I mean, if you want to fully test if the hardware is going to work...

Take out the ubuntu disk and put a hard drive in temp to see.

On Tue, Jan 17, 2017 at 12:14 PM, Victory Omole <vtomole@xxxxxxxxxxx> wrote:
I am on VirtualBox. To be more specific, this is what happens before the blank screen
https://postimg.org/image/mpul3lbxp/ and then this https://postimg.org/image/naxibz0nd/ and finally a blank screen. By pulling out the hard drive, do you mean, take out the ,vdi? That is where Ubuntu is installed.

On Tue, Jan 17, 2017 at 8:55 AM, WebDawg <webdawg@xxxxxxxxx> wrote:

On Mon, Jan 16, 2017 at 9:59 PM, Victory Omole <vtomole@xxxxxxxxxxx> wrote:
I only have one computer, so before taking a risk and installing Xen on it, i wanted to try it on an Ubuntu VM, When i run "sudo apt-get install xen-hypervisor-amd64" and "reboot",I get a blank screen like this.(Image attached)
Could this happen if i tried it on my hardware?

Thank you


Pull the hard drive out and try it on a different one.

Is the VM that you are trying hvm?  You did not say what you where using to virtualize it.
The big deal is virt extensions on the CPU.

Xen is different.  The actual hypervisor is just that...a hvm hypervisor.

Dom0 runs virtualized inside of it.  It just has acess to hardware and management stuff because xen allows it.

It is a simple and kind of wrong explanation, but I think it answers it.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.