[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Cannot boot Dom0 on Hikey

  • To: xen-users@xxxxxxxxxxxxxxxxxxxx
  • From: Nicholas Wei <ncwei@xxxxxxx>
  • Date: Mon, 12 Feb 2018 00:57:05 -0800
  • Delivery-date: Mon, 12 Feb 2018 12:33:55 +0000
  • List-id: Xen user discussion <xen-users.lists.xenproject.org>


I am new to Xen and I was hoping someone could help me with this. I am trying to boot AOSP as dom0 for the hikey board. First I made sure I could boot AOSP on its own, following this: https://github.com/linaro-swg/optee_android_manifest/tree/lcr-ref-hikey-o. I'm using this because I need the OPTEE as well. Next, I tried to boot it under dom0 with Xen 4.10, but I am unable to boot up. Below is a snippet of the kernel where the error starts to occur.

[    3.413039] Mali<2>: [    3.415093] Broadcast: Creating Mali Broadcast unit: Mali_Broadcast
[    3.421451] Unhandled fault: ttbr address size fault (0x96000000) at 0xffffff8009657000
[    3.429503] Internal error: : 96000000 [#1] PREEMPT SMP
[    3.434780] CPU: 0 PID: 1 Comm: swapper/0 Not tainted 4.9.79-04517-g3e7bab5-dirty #32
[    3.442666] Hardware name: HiKey Development Board (DT)
[    3.447956] task: ffffffc0558f1080 task.stack: ffffffc05591c000
[    3.453950] PC is at _mali_osk_mem_iowrite32+0x14/0x20
[    3.459148] LR is at mali_bcast_reset+0x44/0x140
[    3.463825] pc : [<ffffff8008647f74>] lr : [<ffffff8008684778>] pstate: 80000045
[    3.471282] sp : ffffffc05591faf0

The full log can be found here: https://pastebin.com/tdjKGsFK
After this error, everything reboots and I am greeted once again with the grub menu.
My xen.cfg file:

options=console=dtuart loglvl=all dom0_mem=1024M dtuart=/soc/uart@f7113000
kernel=kernel console=hvc0 androidboot.console=hvc0 androidboot.hardware=hikey firmware_class.path=/system/etc/firmware efi=noruntime printk.devkmsg=on

(The options passed to the kernel are essentially the same as what is passed to a normal boot except that the consoles are replaced with "ttyFIQ0"). As stated earlier, I can boot this fine on its own but not under dom0 with Xen. I have tried earlier versions of Xen, notably 4.7-4.9 but the same error persists. I have configured the kernel for Xen support to the best of my knowledge following this: https://wiki.xenproject.org/wiki/Mainline_Linux_Kernel_Configs.

Any advice would be greatly appreciated.

Thank you,


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.