[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Xen on Debian Stretch on UEFI

Hi Ian,

Have a look at this thread on the xen-devel mailing list:

To sum up you need to compile your own grub with the latest version
and do some chain loading (UEFI -> GRUB -> Xen) as it is not possible
to boot Xen directly from UEFI unfortunately.


On Thu, Apr 19, 2018 at 10:12 AM, Ian Macdonald <imac@xxxxxxxxxx> wrote:
> Hi,
> I have been setting up a new server to run Xen, but can't seem to get
> the machine to boot the hypervisor correctly. The server has UEFI
> firmware and I don't think we can run it in BIOS compatibility mode
> because the particular hardware configuration requires full UEFI support
> in order for everything to work.
> I have installed Debian Stretch on the server and can boot via UEFI into
> GRUB and then Linux just fine.
> I have tried following the directions found on this page in order to get
> Xen booting:
> https://wiki.xenproject.org/wiki/Xen_EFI
> I have found that the Debian xen-hypervisor-4.8-amd64 package installs a
> file at /boot/xen-4.8-amd64.efi. Should I be able to use this as my EFI
> boot file? Or do I still need to actually compile Xen from sources in
> order to get a working 'xen.efi' file?
> I have tried copying all files from the /boot directory into
> /boot/efi/EFI/xen/ and then creating /boot/efi/EFI/xen/xen-4.8-amd64.cfg
> with the following contents:
> [global]
> default=xen
> [xen]
> options=console=vga loglvl=all noreboot
> kernel=vmlinuz-4.9.0-6-amd64
> root=UUID=c0589119-f679-4b3c-ac62-7a686ffe00b9 ro
> ramdisk=initrd.img-4.9.0-6-amd64
> I then created an EFI boot entry pointing at Xen:
> efibootmgr -w -L Xen -l "\EFI\xen\xen-4.8-amd64.efi" -c
> When I try to boot from that menu entry, the machine's firmware just
> returns to system setup or to the boot menu, suggesting to me that it
> doesn't recognise or isn't able to boot from xen-4.8-amd64.efi. I also
> tried renaming that file to xen.efi and having the config in xen.cfg
> just in case that made a difference, but the result was the same.
> I have tried booting Debian without using GRUB, using the kernel EFI
> stub to boot, according to the instructions at
> 'https://wiki.debian.org/EFIStub'. I got that to work for booting the
> normal kernel, so I know I can boot the mainline Linux kernel directly
> from the EFI firmware without GRUB, but I've not been able to boot the
> Xen hypervisor.
> Any suggestions or advice would very much appreciated.
> Many thanks,
> -Ian Macdonald
>  GreenNet
> --
> Ian Macdonald
> GPG/PGP: 0778 889F EE5D DFB4 D195 97A7 779B D6BF A305 DEFC
> XMPP/OTR: imac@xxxxxxxxxx  Wire.com: @idmacdonald
> GreenNet Ltd, 56-64 Leonard Street, London EC2A 4LT
> UK Tel:      0330 355 4011
> Intl:        +44 20 7065 0935
> Twitter:     @GreenNetISP
> Registered in England & Wales, Company No. 02070438
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxxx
> https://lists.xenproject.org/mailman/listinfo/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.