[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] EFI boot unsuccessful with Ubuntu 18.04 dom0

Just to be clear, with 'my config', and in particular the use of the patched efi package, my system boots once again without error.
I had overlooked how different your config is from mine. I see your EFI bootloader is loading grub efi file, then I guess grub loads (chainloads?) xen hypervisor (gz image or efi file?).

When I tried anything like that, with the setup provided by the Ubuntu update-grub script and the xen package script for grub, it tried to load the gz image. The boot process got stuck in "Loading initial ramdisk" and nothing else would ever happen. It wouldn't even respond to Ctrl+Alt+Del (which my current setup, booting the efi file from the EFI bootloader directly, does), so I had to hold the power button to reboot.

Then I tried loading the xen efi file from grub, which resulted in a magic number mismatch. It wouldn't even try to load the kernel after that, so no way anyway.

So... how do you get grub to load the xen hypervisor?
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.