[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Help debugging boot crash

I'm drafting a bug report for xen-devel. To do this, I'm trying to
reproduce my issue ("IO-APIC + timer doesn't work") on Ubuntu 19.10.

Unfortunately, I can't figure out how to enable verbose logging on Ubuntu
w/ Xen.

Here's what's displayed on the screen when I boot (followed by a reboot).

    Loading Xen 4.9-amd64 ...
    Loading Linux 5.4.0-24-generic ...
    Loading initial ramdisk ...

Following the Debugging Xen wiki page [1], I've changed my xen.gz grub
line to the following, but it doesn't seem to do anything.

    multiboot2  /boot/xen-4.9-amd64.gz placeholder  loglvl=all guest_loglvl=all 

I've tried removing `quiet splash` from the vmlinuz grub line, with no
success. I've also unsuccessfully tried adding `loglvl=all` to the
vmlinuz and initrd lines.

This is on a Dell XPS 13 laptop, so I don't think accessing a seriel
console would be easy.

On the Xen wiki [2], I noticed that this might be a UEFI issue:
> Go into your BIOS and enable Legacy Booting (non-EFI). If it still
> doesn't work, upgrade the BIOS to its latest version.

My BIOS is up-to-date and has no option to disable UEFI. Yet, somehow
Ubuntu w/ Xen is still booting via grub.

Where should I go from here?

Aaron Janse

[1] https://wiki.xenproject.org/wiki/Debugging_Xen
[2] https://wiki.xenproject.org/wiki/Xen_FAQ_Booting

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.