[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[MirageOS-devel] Struggling a bit with the Hello World applications

I'm going through the Hello World examples on the MirageOS website and on the stackv4 example I'm having some problems. It seems that when I run "mirage configure --unix" the mirage command itself is uninstalled. After being very confused for a while, I accidentally hit CTRL-C while mirage was running because the mirage configure call was taking a long time. Doing so revealed a whole bunch of opam commands running in the background and upon inspection I realised they were downgrading most of the packages. Mirage itself is downgraded to 0.5.

Some points I've noted as feedback from a total newbie:
- There is no verbose switch on the mirage command. When it hangs for a long while I get curious.
- opam reports mirage at version 1.1.2, but mirage --version outputs 1.1.0.
- opam apparently isn't transactional, despite the mirage command failing I'm left with an utterly broken system?
- It doesn't seem like opam caches anything, I spend a lot of time waiting for downloads. Any simple way to speed this up?

I get a lot of these "external solver failed with inconsistentt result". Here's an example from running "opam install mirage" after it has been uninstalled by the stackv4 example:

$ opam install mirage
[WARNING] External solver failed with inconsistent return value. Request saved to "/home/vagrant/.opam/log/solver-error-29875-1.cudf"
Falling back to the internal heuristic.
The following actions will be performed:
Â- remove tuntap.0.7.0
Â- remove ocplib-endian.0.3
Â- remove uri.1.6.0
Â- remove fieldslib.109.20.03
Â- remove ipaddr.2.2.0
Â- remove optcomp.1.5
Â- remove re.1.2.1
Â- remove sexplib.110.01.00
Â- remove stringext.0.0.1
Â- remove type_conv.109.53.02
Â- install cstruct.0.4.0 [required by mirage]
Â- install lwt.2.4.3 [required by mirage]
Â- install xenstore.1.0.0 [required by mirage]
Â- install mirage.0.5.0
4 to install | 0 to reinstall | 0 to upgrade | 0 to downgrade | 10 to remove
Do you want to continue ? [Y/n]Â

Now, mirage 0.5 clearly isn't what I want, so I typically end up deleting the .opam folder and restarting from scratch. This is tedious to say the least.

I've tried this on Ubuntu 12.04 and 14.04 (both 64 bit).

Andrà NÃss
MirageOS-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.