[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [MirageOS-devel] Struggling a bit with the Hello World applications

On 5 May 2014, at 08:42, André Næss <andre.naess@xxxxxxxxx> wrote:

I'm going through the Hello World examples on the MirageOS website and on the stackv4 example I'm having some problems. It seems that when I run "mirage configure --unix" the mirage command itself is uninstalled. After being very confused for a while, I accidentally hit CTRL-C while mirage was running because the mirage configure call was taking a long time. Doing so revealed a whole bunch of opam commands running in the background and upon inspection I realised they were downgrading most of the packages. Mirage itself is downgraded to 0.5.

Can you try to install the aspcud external solver via "apt-get install aspcud".  It should be available in both versions of Ubuntu you tried.  I promoted aspcud to a recommended dependency in the Debian package, but will file an Ubuntu bug to do the same as well.  I have an odd feeling that you already have aspcud though, since the error below reports an inconsistent result.

Some points I've noted as feedback from a total newbie:
- There is no verbose switch on the mirage command. When it hangs for a long while I get curious.

Yep, I've got a trivial local patch to fix this out that I'll push.   You can also just set the OPAMVERBOSE environment variable as a workaround.

- opam reports mirage at version 1.1.2, but mirage --version outputs 1.1.0.

Fixed locally too (really need to automate that in the build system).

- opam apparently isn't transactional, despite the mirage command failing I'm left with an utterly broken system?

OPAM does do error recovery by going back to the original patchset, but possibly not if the external solver failure is messing up its notion of the universe.  In normal use it will perform error recovery with the original set of packages being reinstalled.

- It doesn't seem like opam caches anything, I spend a lot of time waiting for downloads. Any simple way to speed this up?

Much of this has been improved in OPAM 1.2dev, which will be released soon-ish. e.g.:

I get a lot of these "external solver failed with inconsistentt result". Here's an example from running "opam install mirage" after it has been uninstalled by the stackv4 example:

$ opam install mirage
[WARNING] External solver failed with inconsistent return value. Request saved to "/home/vagrant/.opam/log/solver-error-29875-1.cudf"
Falling back to the internal heuristic.
The following actions will be performed:
 - remove tuntap.0.7.0
 - remove ocplib-endian.0.3
 - remove uri.1.6.0
 - remove fieldslib.109.20.03
 - remove ipaddr.2.2.0
 - remove optcomp.1.5
 - remove re.1.2.1
 - remove sexplib.110.01.00
 - remove stringext.0.0.1
 - remove type_conv.109.53.02
 - install cstruct.0.4.0 [required by mirage]
 - install lwt.2.4.3 [required by mirage]
 - install xenstore.1.0.0 [required by mirage]
 - install mirage.0.5.0
4 to install | 0 to reinstall | 0 to upgrade | 0 to downgrade | 10 to remove
Do you want to continue ? [Y/n] 

Now, mirage 0.5 clearly isn't what I want, so I typically end up deleting the .opam folder and restarting from scratch. This is tedious to say the least.

I've tried this on Ubuntu 12.04 and 14.04 (both 64 bit).

Thanks for the useful feedback!


MirageOS-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.