[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [MirageOS-devel] Mirage on Linux Mint 17

Hello both,

Thank you for your help - I had success with 0install (using zeroinstall-injector, it worked after a couple of initial error messages), and now have OPAM 1.2.2 installed properly too, which appears to be installing packages correctly. Mirage and its dependencies are now installed without issue.

Thank you again.




On 27/11/2015 16:59, Thomas Leonard wrote:

On 27 November 2015 at 16:25, Richard Mortier
<richard.mortier@xxxxxxxxxxxx> wrote:
Hi Alex; On 27 November 2015 at 11:18, A.G. Rakowski <agr37@xxxxxxxxx> wrote:
I'm on Linux Mint 17, Cinnamon, with OPAM v1.1.1 and OCaml 4.02.3 installed and working fine, except regarding the following. When I run the command `opam install mirage`, I receive the following error:
Aha! I think the problem may be here -- that's an old version of OPAM. Can you get OPAM 1.2.2 installed somehow? (By hand is pretty straightforward if it isn't packaged for Mint yet.)
On most platforms, you can install "0install-core" or
"zeroinstall-injector" from your distribution and then (as your user,
not as root):

$ 0install add opam http://tools.ocaml.org/opam.xml

to get a recent opam with its dependencies, including aspcud. Let me
know if it's broken anywhere.

MirageOS-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.