[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [win-pv-devel] [xs-devel] Question about testing new windows pv drivers on xenserver

> -----Original Message-----
> From: xs-devel-request@xxxxxxxxxxxxxxxxxxx [mailto:xs-devel-
> request@xxxxxxxxxxxxxxxxxxx] On Behalf Of Fabio Fantoni
> Sent: 24 March 2016 14:29
> To: Paul Durrant; win-pv-devel@xxxxxxxxxxxxxxxxxxxx; xs-
> devel@xxxxxxxxxxxxxxxxxxx
> Subject: Re: [xs-devel] Question about testing new windows pv drivers on
> xenserver
> Il 24/03/2016 13:55, Paul Durrant ha scritto:
> >> -----Original Message-----
> >> From: Fabio Fantoni [mailto:fabio.fantoni@xxxxxxx]
> >> Sent: 24 March 2016 12:49
> >> To: win-pv-devel@xxxxxxxxxxxxxxxxxxxx; Paul Durrant
> >> Subject: Question about testing new windows pv drivers on xenserver
> >>
> >> Hi, I'm going crazy about many upgrade/remove pv drivers problems, and
> >> also other additional problem with windows 10 (big updates, ovmf pv disk
> >> only ecc...)
> >> I tried to do some fast tests with xenserver core and win pv drivers
> >> signed with installer included for see if the same problems are
> >> reproducible also with them or not.
> >> I downloaded and installed XenServer Dundee beta.3, I saw that use xen
> >> 4.6 but qemu seems still use the old traditional instead.
> >> I saw there is also the upstream one binary
> >> (/usr/lib64/xen/bin/qemu-system-i386), I did a fast google search and I
> >> setted these in /etc/xenopsd.conf:
> >> qemu-system-i386=/usr/lib64/xen/bin/qemu-system-i386
> >> use-upstream-qemu=true
> >> And rebooted toolstack (xe-toolstack-restart) but seems it still using
> >> qemu traditional instead (looking ps and initial boot screen).
> >> I also tried:
> >> chkconfig --del xenopsd-xc
> >> chkconfig --add xenopsd-xenlight
> >> following
> >> https://lists.xenserver.org/sympa/arc/xs-devel/2014-01/msg00035.html
> >> but trying to start the vm (with xe vm-start vm=...) the command
> >> "freeze" without output and I found nothing in logs.
> >>
> >> Is there anywhere an howto about using the upstream qemu with
> >> xenserver?
> > In short, I'm pretty sure you can't. However, if you ask this question on 
> > the
> xs-devel list (at xenserver.org) then someone from the toolstack team may
> be able to advise how you might do it.
> Thanks for your reply.
> I supposed you are using xenserver core and upstream qemu, can you tell
> me what environment are you using please?

For upstream development I don't use XenServer. My preferred environment is 
generally a debian dom0 (I have wheezy and jessie hosts at the moment) but I 
build my own kernel (generally based on net-next 'cos I'm usually hacking on 
netback) and my own Xen and I usually just stick with whatever QEMU upstream 
that brings in.

> Added xs-devel for the question above, @xs-devel: can someone tell me
> how I can use upstream qemu with xenserver core using xapi please?
> Other replies/questions below.
> >
> >> I also tried to do a fast install of a windows 7 domU using xencenter
> >> and installing pv driver from guest-tools.iso  but I not understand if
> >> are the new one (>=8.1) or older, based on version I found seems older,
> >> or I'm wrong? In that case where I can find newer driver signed and
> >> including installer (if exist) for doing some fast tests?
> >>
> > The tech. preview 3 drivers are the 8.1 drivers.
> I download dundee beta 3 from here:
> http://xenserver.org/overview-xenserver-open-source-
> virtualization/prerelease.html
> Is the tech preview 3 you mean is the same or a different one? if
> different where I can found it?
> Another thing I want try is windows live snapshot with vss, I saw this:
> https://github.com/xenserver/win-xenvss but in drivers installed in
> xenserver from integrated guest-tools seems not available
> >
> >> My goal would be to test on xenserver with qemu upstream, new pv
> driver
> >> (at least 8.1) signed with complete installer to see whether or not
> >> there are the same problems that I have with xen and pv drivers
> >> individual not signed.
> >>
> > Why do you need upstream QEMU?
> Mainly for spice (that now is full features also upstream for hvm domUs
> using xen 4.6)
> Also needed for other features, for example I do occasional testing with
> ovmf (uefi support for domUs), pv disks using it (for faster boot) but
> unfortunately I can't consider to use it in production shortly because
> on windows 10 bigger updates disables the pv drivers making domUs not
> working, I suppose do it with not signed drivers but after long time
> waiting signed xen project pv drivers are still not available (I want
> try xenserver with the full signed one instead also for retry these tests)

Discussions are still ongoing with the Linux Foundation to see if they are 
willing to sign up to Microsoft's attestation agreement. This is a 
pre-requisite to signing drivers for Windows 10.


> Thanks for any reply and sorry for my bad english.
> >
> >    Paul
> >

win-pv-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.