[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-API] opam build howto

Hi Nick,

I would suggest to get at least minimum Xen (even a year old working) following steps mentioned earlier.

Do you have any further details from logs? Maybe some dependency needs to be installed manually. This is most probably the case. Other issue I came across was that some binaries were expected at specific locations, i.e. at /usr/bin vs /bin which caused xen installation wizard to fail.

Another option is to give it a try, install LTS 14.04 based on ISO.
Pull git commit from the beginning of year and give it a try. It should not complain about these missing dependencies.

This should give you working xen installation. Once this is working, you have base system and can give it a try with more up to date version.

Unfortunately I don't have time now to try with Ubuntu 15.xx and building Xen.

btw. I'm also hesitating to upgrade my environment to more recent version as it just works. Sometimes some tasks are getting stuck, but generally speaking it works.


On 2015-12-31 12:26, Nick Betteridge wrote:
Hi Dawid

Thanks for the offer of  helping out. I've just spent the whole morning
installing various versions of centos (6.7 minimal, minimal-gui; 7
minimal) and when trying to use buildroot to compile the rpms I always
get the same error (below). I already know that buildroot Ubuntu 14.04
will fail due to the version of findlib required is not available for
14.04. I'm running Ubuntu 15.04 as a desktop and buildroot doesn't build
on that either.

This is from a minimum centos install and then following the
instructions for buildroot, everything works fine up until make - as
mentioned above, this is the same error for 6.7 too - :

[nick@igor buildroot]$ make
Populating build directory: _build...done
Updating dependencies...
[FETCH] _build/SOURCES/ocaml-cohttp-0.15.2.tar.gz
[RPMBUILD] _build/SRPMS/ocaml-cohttp-0.15.2-2.el7.centos.src.rpm
warning: Could not canonicalize hostname: igor.syntactics.com
[FETCH] _build/SOURCES/ocaml-uri-1.6.0.tar.gz
[RPMBUILD] _build/SRPMS/ocaml-uri-1.6.0-1.el7.centos.src.rpm
warning: Could not canonicalize hostname: igor.syntactics.com
[FETCH] _build/SOURCES/findlib-1.5.5.tar.gz
[RPMBUILD] _build/SRPMS/ocaml-findlib-1.5.5-1.el7.centos.src.rpm
warning: Could not canonicalize hostname: igor.syntactics.com
[MOCK] _build/SRPMS/ocaml-findlib-1.5.5-1.el7.centos.src.rpm
ERROR: Exception(_build/SRPMS/ocaml-findlib-1.5.5-1.el7.centos.src.rpm)
Config(epel-7-x86_64) 1 minutes 0 seconds
ERROR: Command failed. See logs for output.
  # /usr/bin/yum --installroot
--releasever 7 groupinstall buildsys-build --setopt=tsflags=nocontexts
make: ***
Error 30
[nick@igor buildroot]$

It would be really great if building for centos (as this is the
preferred platform) could be set up on travis so that a build for a
designated platform always works and can be replicated by anyone trying
to build the rpms.

Very best,

On 30/12/15 21:13, Dawid Kowalski wrote:
Hi Nick,

Just to confirm, I did follow buildroot steps to build packages.
Having said that, I'm a bit afraid to update them with the latest
build. Maybe the problem is with one of the latest revisions.
The one I'm using is back from the beginning of the year and I've
installed separately ffs build. Please check the mailing list archive.

I've used LTS 14.04 as build host too.


On 2015-12-30 20:21, Dawid Kowalski wrote:
Hi Nick,

I'll be happy to help to get you running Xenapi as I agree this is
great piece of code. It just takes so much effort to get it running.

The easiest for me would be to share with you packages I've built
directly from sources. But equally, you could prefer to get specific
git commit and follow same instructions I did.

More or less at the high level I did just follow standard
instructions. I did run into some problems with ffs and putting it on
ZFS, but this is different story. You can certainly find my posts
within archive.

The issue I did fall into was:

Check the buildroot instructions please.

If you'd still have questions, let me know.

btw. I might reply with delays, maybe even next week as have some

Good luck,

On 2015-12-30 11:19, Nick Betteridge wrote:
Hi David,

Did you mean you had problems with installing Xapi or Xen?

I've never been able to install xapi onto ubuntu via buildroot - I
originally tried on 14.04, and then upgraded my desktop to Ubuntu 15.04
to deal with findlib issues. I'm at the point where I've got the xapi
packages to compile via opam but now need to try and find a harness to
take those packages and build something that will allow be to run

Recently got hold of another machine to try out buildroot with centos.
Installed centos 7 and buildroot failed straightaway with a findlib

This is all a real shame as it is a great bit of software but there
seems to be no qos built in to make any form of build working straight
out of the box - things are adjusted within the buildroot scripts and
then nothing is tested to make sure that the fix works.

No hair left to pull out.


On 30/12/15 10:01, Dawid Kowalski wrote:
Hi Nick,

I've had some problems installing Xen on Ubuntu 14.04 hence I've went
ahead and built all packages locally.


On 2015-12-29 17:15, lists.nick.betteridge wrote:

I'm just trying to build xapi via opam on Ubuntu.

The installation went OK (apart from xapi-rrd.0.9.1 [err:
ocamlfind: Is
a directory] and tar-format.0.4.1 [mismatch on interface/impl -
Make_KV_RO(BLOCK), value `id' is required but not provided]).

I'd like to build the installation/server from the installed
libraries -
could someone possibly point a finger to where I might find
on how to do this?


Xen-api mailing list

Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.