[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Virtual block devices (vbd) still not working... :-(

Ian wrote:

>> I haven't been able to try the "virtual disk" stuff as I haven't a
>> spare partition on my test machine. I'll make one free if you're
>> still having problems ;-)

>With the 3 lines hacked out of xenctl, I've successfully
>"formatted" a partition to contain virtual disks, created a
>virtual disk, attached it as a "virtual block device" to domain0,
>made a file system on it, and even mounted it.
>Amazingly, the code hasn't rotted! (other than the java goop)
>The log is attached, with comments. The UI for the tools isn't exactly
i>ntuitive. The web-based interface was pretty cool until it
>iap10 > mkdir /var/lib/xen
>#we need a directory in which the vdstate.xml file will be
>#created. This keeps track of which chunks of disk space are used
>#by which virtual disks.
>iap10 > xenctl partitions add -psda15 -f
>warning: state file not found [/var/lib/xen/vdstate.xml]
>Added partition sda15

I've tried Ian's guide in the post to the mailing list to create 
vds and vbds and had no success.

xenctl always reported that it added the partition, created the vd
and created the vbd for domain 0 and also the vd show and vbd show
gave the correct display of the created vds and vbds.

But, as I tried to mkfs on /dev/xvda , mkfs showed an error
message that the filesystem reported to have zero size ?

Then I tried fdisk /dev/xvda  and it complained about not having
any partition label on it and that I have to set the number of
Entering the 'p' option in fdisk showed an empty partition table
and 255 heads, 63 sectors, 0 cylinders ??

Trying the same on /dev/xvdb showed the same result with mkfs
but fdisk now reported "unable to read /dev/xvdb".
(I added the local ide partition /dev/hda7 with xenctl partition add, 
and #0 as the number of the vbd).

Something seems to be broken here....

I also recognized another strange thing:
Everybody is showing examples with vbd create and using the -w flag in order
to enable write access to the vbd. 
But I have to use "-rw" with xenctl vbd create, otherwise I end up only with
Also, with a lot of xenctl commands there is a x<subst> option. What's the
meaning of that ?
Are you using a newer version of xen than me ? ;-)
Mine was copied from the xen-1.0 demo disk.
I also used the source tree from this disk and compiled xeno and xenolinux
this tree.

Anybody else has these strange problems with virtual block devices and
disks ? Any solutions ?



NEU FÜR ALLE - GMX MediaCenter - für Fotos, Musik, Dateien...
Fotoalbum, File Sharing, MMS, Multimedia-Gruß, GMX FotoService

Jetzt kostenlos anmelden unter http://www.gmx.net

+++ GMX - die erste Adresse für Mail, Message, More! +++

This SF.net email is sponsored by: SF.net Giveback Program.
SourceForge.net hosts over 70,000 Open Source Projects.
See the people who have HELPED US provide better services:
Click here: http://sourceforge.net/supporters.php
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.