[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: Virtual block devices (vbd) still not working... :-(

> xenctl always reported that it added the partition, created the vd
> and created the vbd for domain 0 and also the vd show and vbd show
> gave the correct display of the created vds and vbds.

This is an odd one. Can you send me the output of "vd show".
> But, as I tried to mkfs on /dev/xvda , mkfs showed an error
> message that the filesystem reported to have zero size ?

Please can you show me the output of "cat /proc/xeno/vhd"

> Then I tried fdisk /dev/xvda  and it complained about not having
> any partition label on it and that I have to set the number of
> cylinders.
> Entering the 'p' option in fdisk showed an empty partition table
> and 255 heads, 63 sectors, 0 cylinders ??

There wouldn't have been a valid partition table on the virtual
disk, so fdisk would have just read rubbish and got confused. You
could just delete all the bogus partitions, but using "dd
if=/dev/zero of=/dev/vbda count=5" is probably safest.

In normal circumstances, fdisk should then be happy.

> Trying the same on /dev/xvdb showed the same result with mkfs
> but fdisk now reported "unable to read /dev/xvdb".

Have you done a "vbd create -v1 -n0 -w" for xvdb, or are you
getting this error on non existent vbd's?

> I also recognized another strange thing:
> Everybody is showing examples with vbd create and using the -w flag in order
> to enable write access to the vbd. 
> But I have to use "-rw" with xenctl vbd create, otherwise I end up only with
> read
> access.

That really is odd. Write access seems to work for me with the
"-w" flag. I don't believe there is a "-rw" flag as read access
is the default.

> Also, with a lot of xenctl commands there is a x<subst> option. What's the
> meaning of that ?

The -x flag comes into play if you're using the '+' postfix to
any of the entries in your /etc/xenctl.xml (e.g. for the new
domain's IP address or disk partition). By default, xenctl will
add the new domains domainID to the contents all fields
postfixed by a '+' (i.e. /dev/sda7+ for domain 2 becomes
/dev/sda9). Rather than using the domainID, you can force xenctl
to use a particular value in the calculation with the "-x" option.

[Note to self: We desperately need some documentation for xenctl.]

> Are you using a newer version of xen than me ? ;-)

I'm using the xeno-unstable.bk tree, which is 30 changesets ahead
of the 1.0 tree, but none of them have gone anywhere near the vbd

I think Keir kindly volunteered to do a code review of that
section of code over the weekend, so hopefully he'll spot

I'm confident we'll get things working for you eventually...


This SF.net email is sponsored by: SF.net Giveback Program.
SourceForge.net hosts over 70,000 Open Source Projects.
See the people who have HELPED US provide better services:
Click here: http://sourceforge.net/supporters.php
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.