[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen-Unstable : no eth0 when boot up

> I used to use xen 1.2,and it worked fine. Now I wanna to try out the xen gdb
> debug stub, so switched to xen-unstable.
> I just 'make world' and 'make install', according to the README.And the grub
> configure is like:
> title Xen_1.3 / XenoLinux_1.3 2.4.26
>         kernel /xen.gz dom0_mem=131072 com1=115200 8n1 noht
>         module /vmlinuz-2.4.26-xen0 root=/dev/hda5 ro concole=tty0 3

There should be a comma in the "com1=115200,8n1".

Also, you probably don't need the "console=tty0" (in which you
have a typo anyway).

> But when booting up, it doesn't have network connection. Only has localhost
> domain name and address.

What Ethernet card do you have in the machine (i.e. what's the
name of the driver you use under Linux)?  It's possible that the
default dom0 config currently doesn't include it, though we tried
to include most popular cards.

You can enable it in the normal way by going into
linux-2.4.26-xen0 and editing .config and then doing a "make dep"
"make dist".


This SF.Net email sponsored by Black Hat Briefings & Training.
Attend Black Hat Briefings & Training, Las Vegas July 24-29 - 
digital self defense, top technical experts, no vendor pitches, 
unmatched networking opportunities. Visit www.blackhat.com
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.