[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Status of USB on 2.4.26-uml0?


I noticed Xen has made quit a lot of progress since the 1.2 release, and
so I decided to give the unstable version a spin :-)
I installed the xen.gz and the 2.4.26-xen0 images, and tried to use it to
boot my Fedora Core 2 setup.Much to my surprise, I ran into very little 
problems (good job guys!),
but there was one thing still missing; the USB drivers aren't loaded.
For me USB is essential, since I have USB network card, and an USB mouse
and keyboard.With my PS2 keyboard plugged in, I tried to load the USB drivers 
that I
need, usbnet and usb-storage (well, and usblp, scanner, hid, etc).However, it 
seemed that the uhci driver wouldn't load, it complained about
not being able to find/allocate IRQ... Same also for the ehci driver 
:-(Browsing through the mail archives, I noticed someone had a similar
problem in march, but he had 'patched' the kernel to support USB, wheras
now, I could just choose it from the default kernel configuration menu.
My only question is, is this supposed to work currently? Has anyone had
success in getting USB up and running? Or is this still a work in progress
known not to work?

Warm regards,

Xen in its current state looks very promising to me!

SF.Net email is sponsored by Shop4tech.com-Lowest price on Blank Media
100pk Sonic DVD-R 4x for only $29 -100pk Sonic DVD+R for only $33
Save 50% off Retail on Ink & Toner - Free Shipping and Free Gift.
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.