[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] system lockup

Hash: SHA1

Ian Pratt wrote:
>>I've recently managed to get a 2.6.7 dom0 to boot without any major
>>problems.  I had seen the hwclock issues and the nosegfixup issues fly
>>by and these seem to be all worked out now.
> That's good to hear.
>>It seems that once I log into my gnome session, everything is aok for
>>the first little while, until eventually I get a segfault pop-up for
>>wnck-applet.  I've never seen this segfault before, and am not sure if
>>it is xen or 2.6.7 related (I'm still running a 2.6.1 variant).
>>However, a few seconds later, whether or not I click the 'ok' in the
>>segfault dialog, the machine seems to lock hard.
> Is this all in domain 0 or another domain?

This is all dom0.  I haven't had the chance to load up any other domains
yet.  My main concern at this point is getting my hardware working :)

> Can it be repeated with 2.4, or will your filesystem not boot
> with a 2.4 kernel? (BTW: what file system are you using?)
>>I've tested this w/ & w/o both a) removing the /lib/tls directory and b)
>>the nosegfixup kernel option.
> It's useful to know its not a tls issue.
>>Has anyone else seen this?  or possibly know of any other cause for this?
> Could you hook up a serial console to the machine? If you start
> Xen with the appropriate (e.g. 'com1=115200,8n1') option there's
> a fair chance that either Xen or more likely, domain 0, will
> write some sort of crash message to the console when the machine
> locks. A 'debug=y' build of Xen might help.

I'll hopefully be able to try something eventually.  I just moved, so at
this point I'm living out of cardboard boxes 8)

Out of curiosity, is there any way to get the Xen console/crash dumps on
the console (as opposed to serial)?

>>A while ago, I tried building the xenolinux-2.6.7-dom0 kernel with a
>>pentium II cpu target.  The system appeared to boot up properly, however
>>X couldn't start as there seemed to be a mysterious SIGBUS being sent.
>>For now, I'm using a PIV build on this PII..
> That's very weird. The other way around I could sort of
> understand...

Ah, I just checked my latest build, and it is in fact a PII build.  I
saw this issue a couple days ago: I may have had an inconsistent build.
Sorry for the noise :)

- --
Mike Waychison
Sun Microsystems, Inc.
1 (650) 352-5299 voice
1 (416) 202-8336 voice

NOTICE:  The opinions expressed in this email are held by me,
and may not represent the views of Sun Microsystems, Inc.
Version: GnuPG v1.2.4 (GNU/Linux)


SF.Net email is sponsored by Shop4tech.com-Lowest price on Blank Media
100pk Sonic DVD-R 4x for only $29 -100pk Sonic DVD+R for only $33
Save 50% off Retail on Ink & Toner - Free Shipping and Free Gift.
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.