[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xen-2.0 20040910 problems

Ian Pratt wrote:

I have been experimenting with xen 2.0 and before that with xeno-unstable. It
has proved interesting and promising

However, the last few updates have been problematic. In particular it looks as
if the ext3 filesystem is not correctly handled.

Can you give us an idea when it last worked reliably for you?

The previous snapshot - 20040906 - worked ok but encountered "Kernel panic: Unable to reduce memory reservation ..." as discussed elsewhere in this list.

Recent history:

   20040907:  occasional kernel BUGs
   20040908:  instant reboot loop when booting xen
   20040909:  mysterious filesystem problems
   20040910:  mysterious filesystem problems

I suspect that these are all a result of experiencing some
virtual memory bug.
At present the snapshot for 20040911 seems to show no signs of the filesystem problem, so I probably was seeing a side effect of some of the changes you were making in the pagetable system.

However I have seen at least one instance of the "Kernel panic: Unable to reduce memory reservation ..." problem.

It's pretty odd, as we haven't seen any problems in our testing,
but its possible that our automated testing doesn't run enough
concurrent domains to tweak it.

Can you tell us a bit more about your setup, e.g. SMP? Xeon or
CPU: AMD Athlon(tm) XP 2400+ stepping 01 ('uname -a' shows architecture as i686). 512Mbytes RAM. El-cheapo-self-build(tm). The Xen kernels are built straight out of the snapshot with no local configuration.

What are the other domains doing when 'rpm -qa' explodes?
Nothing much (no exerciser running). But running sshd, postfix, apache, proftpd, webmin, xinetd. Each xenU domain has only 32Mbytes, so the virtual memory would have been fairly active. Each domain would like to have a swap partition but doesn't get one as yet largely because I haven't got round to changing the configuration from the minimum required to make untrusted domains boot and run. But I'm not clear how swap and xen are intended to interact, and whether I should configure swap devices for untrusted domains.

What version of libc are you using i.e. 'ldd /bin/rpm' ? (We've
never used mandrake, but I doubt this is significant)
....$ ldd `which rpm`
       linux-gate.so.1 =>  (0xfbffd000)
       librpm-4.2.so => /usr/lib/librpm-4.2.so (0x40029000)
       librpmdb-4.2.so => /usr/lib/librpmdb-4.2.so (0x40082000)
       librpmio-4.2.so => /usr/lib/librpmio-4.2.so (0x4016d000)
       libpopt.so.0 => /lib/libpopt.so.0 (0x401af000)
       libelf.so.1 => /usr/lib/libelf.so.1 (0x401b7000)
       libbeecrypt.so.6 => /usr/lib/libbeecrypt.so.6 (0x401c9000)
       librt.so.1 => /lib/i686/librt.so.1 (0x401e7000)
       libpthread.so.0 => /lib/i686/libpthread.so.0 (0x401fa000)
       libbz2.so.1 => /usr/lib/libbz2.so.1 (0x4024c000)
       libc.so.6 => /lib/i686/libc.so.6 (0x4025b000)
       /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

I very much doubt if use of Mandrake has much to do with it. My main issue with Mandrake is that the standard boot files need quite a lot of tweaking if you want to have an nfs root. But this also applies to some other distributions I've tried.

If you can narrow down to a simple to reproduce test case I'm
surewe can find and fix this.
It currently looks to have been a passing glitch.

On a different topic, I have never yet seen the web interface work for long
enough to be useful - it always crashes with the int-text type clash that was
mentioned somewhere in the changelogs as having been fixed.

The web interface is very much a work-in-progress that we're
hoping other people will contribute on. 
I realised that, but hadn't yet made very serious attempts to find my way into the guts of the python.


This SF.Net email is sponsored by: YOU BE THE JUDGE. Be one of 170
Project Admins to receive an Apple iPod Mini FREE for your judgement on
who ports your project to Linux PPC the best. Sponsored by IBM. Deadline: Sept. 13. Go here: http://sf.net/ppc_contest.php
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.