[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] v2.6 xen0 defconfig

In any case, recent fixes should now mean that xend correctly
daemonises itself with no external assistance.

 -- Keir

> " > Something during xend startup needs iptables.  The network script
> " How does xend fail for you without these table configured? I run with
> The domain had no network access, because the vif wasn't being added to
> the bridge correctly.   Turns out the problem was that xend wouldn't run
> the network script successfully when run outside a normal foreground
> process context.  The config options were not the real problem (unlike
> what I had posted last time). oops
> After further review, I think I know what happened.   When I started
> xend remotely,   xenU domain's could not send or recv any network packets.
> While trying to figure why networking failed,  I had run
> the xen/scripts/network file by hand.  The script has anit-spoof on by
> default, which is what requires the ipt_physdev and iptable_filter module.
> After I ran network by hand, the remote tool I used (a customized gexec)
> could start xend OK.  I mistakenly concluded the iptables modules were
> required.
> Later I discovered the tool's deamon-ize option didn't play well with
> xend, but Debian's start-stop-daemon can daemonize xend just fine.
> So start-stop-daemon solves my original problem, and the extra config
> options I posted are just needed when running xen/scripts/network with
> anti-spoof turned on. 

This SF.Net email is sponsored by: YOU BE THE JUDGE. Be one of 170
Project Admins to receive an Apple iPod Mini FREE for your judgement on
who ports your project to Linux PPC the best. Sponsored by IBM.
Deadline: Sept. 24. Go here: http://sf.net/ppc_contest.php
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.