[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] xen.lowlevel.xu.PortError: Failed to map domain control interface

> >Was the failed domain still shown as present on xm list? If you were
> >running a debug build (with a serial line), we'd be able to find out
> >more.
> >
> I am getting the same with the latest 2.0.5.   I restarted 
> nps1 domain 
> form a console and that worked, then I tried to restart the 
> dns domain 
> from a console and it hung after the "Restarting system."  message.
> # xm shutdown dns
> Error: Internal Server Error
> # xm list
> Name      Id        Mem(MB)   CPU    State     Time(s)   Console
> Domain-0  0            123      0    r----     9522.8
> dns       3              0      0    ---s-     5341.5      9603
> nps1      2            127      0    -b---        7.5      9602
> I have attached the xend-debug.log

This is pretty odd. It would be really helpful if you could try running
a debug build -- "make debug=y world". It's possible that "xm dmesg"
would then tell us something.
Even better sould be to get a serial line on the machine, then hitting
'o' would tell us what's going on.

BTW: Something that would be interesting to know is whether the vifX.0
for the domain (where X=3 in the above case) still exists in domain 0 if
you do an "ifconfig vifX.0"


This SF.net email is sponsored by Microsoft Mobile & Embedded DevCon 2005
Attend MEDC 2005 May 9-12 in Vegas. Learn more about the latest Windows
Embedded(r) & Windows Mobile(tm) platforms, applications & content.  Register
by 3/29 & save $300 http://ads.osdn.com/?ad_idh83&alloc_id149&op=click
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.