[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] misleading names in xen memory management code

  • To: "Li, Xin B" <xin.b.li@xxxxxxxxx>, "xen-devel" <xen-devel@xxxxxxxxxxxxxxxxxxx>
  • From: "Ian Pratt" <m+Ian.Pratt@xxxxxxxxxxxx>
  • Date: Sat, 29 Oct 2005 03:25:48 +0100
  • Delivery-date: Sat, 29 Oct 2005 02:22:56 +0000
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>
  • Thread-index: AcXcLO8xmuQY6DAYQpmS7aG4WO2Z4gAAngFw
  • Thread-topic: [Xen-devel] misleading names in xen memory management code

 > Keir, I think we have some misleading names in xen memory management
> code:
> 1) #define page_to_pfn(_page)  ((unsigned long)((_page) - 
> frame_table)) Actually, it should be page_to_mfn.
> 2) #define l1e_from_pfn(pfn, flags)   \
>     ((l1_pgentry_t) { ((intpte_t)(pfn) << PAGE_SHIFT) |
> put_pte_flags(flags) })
> Seems l1e_from_mfn(mfn, flags) is much more clear.
> Am I right?

Yep, these are functions from the very early days of Xen, before the
terminology was properly developed. They could usefully be renamed.

While doing this, it would be well worth paying attention to uses of
page_to_pfn to check that the value returned is never shifted left
PAGE_SHIFT without appropriate casting (for PAE).


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.