[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] domU's on SLES 10.0b3 crashing dom0

  • To: xen-devel@xxxxxxxxxxxxxxxxxxx
  • From: Thorolf Godawa <nospam@xxxxxxxxx>
  • Date: Wed, 01 Mar 2006 13:34:37 +0100
  • Delivery-date: Wed, 01 Mar 2006 12:35:08 +0000
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

Hi all,

I installed SLES 10.0b3 with XEN on some test-systems and created a SLES 10.0b3-image for use with domU's.

The installation and booting of this domU was no problem, but on some systems the host dom0 restarts if I generate some IP-traffic from the guest.

This happens on an old AMD Athlon 1,3GHz, an old Intel P3 and an Intel desktop with P4 HT/VT/EM64T but not on an Intel server with Xeon HT/VT/EM64T.

I also tried SLES 10.0b5 (and b4), but the package-management is not working yet, the installation is not correct (on the first try during the installation only CD1 was installed, on the second try the installation asked for all CDs but continued in textmode), I'm not able to install packages later because yast doesn't show anything to install, heartbeat didn't work anylonger (only tried in b4) and the script "/usr/sbin/xenmon.py" is not working anymore (doesn't show any cpu-load). The good thing with beta5 was that the SLES 10.0b3-guests where running quite stable, even with network-load!

Next step was updating the SLES 10.0b3 installation with the newer SLES10-i586-changeset8910.tar.bz2 .

Unfortunately I already had no success to install the new kernel with "yast -i kernel-xen-2.6.16_rc3_git6-2.i586.rpm", I get the following error:
Including:      initramfs fsck.ext3.ext3
Bootsplash:     SuSE-SLES (1280x1024)1024)
/etc/bootsplash/themes/SuSE-NLD/animations/throbber.mng: No such file or directory
1446 blocks
Unknown option: force
SYNOPSIS: /sbin/update-bootloader {--image file} [--initrd file] [--default] [--previous] {--add|--remove}
Unknown option: refresh
SYNOPSIS: /sbin/update-bootloader {--image file} [--initrd file] [--default] [--previous] {--add|--remove} error: %post(kernel-xen-2.6.16_rc3_git6-2.i586) scriptlet failed, exit status 1

But I was able to install the other packages from the tar.bz2!

Now my Linux-domU's are running stable, they don't crash my dom0, but I'm not able to start vmx-guest anymore:

# xm create -f w2k3cit.vmx
Using config file "w2k3cit.vmx".
Error: Error creating domain: unknown image type: vmx

and the xenmon.py is not running anymore too:

# python xenmon.py
xenbaked: no process killed
ms_per_sample = 100
ERROR: Failed to mmap trace buffers (14 = Bad address)

Does s.b. has an idea how to get SLES 10.0b3 als host more stable or how to get b5 running better?

Thanks a lot for your answer,

Chau y hasta luego,


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.