[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Re: [Xen-changelog] [xen-unstable] [LINUX][XENBUS] replace xenbus_transaction_t with an opaque transaction ID.

* Anthony Liguori (aliguori@xxxxxxxxxx) wrote:
> Can't we just go back to the original semantics and s/XBT_NIL/NULL/g.  
> The whole reason XBT_NULL was introduced was that it switched to an 
> integer and NULL used to represent no transaction.

Don't think there's a semantic change here.  Just syntax.
And these opaque objects are passed by value not ref, so NULL wouldn't
be right.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.