[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: [Xen-users] Credit Scheduler!

  • To: xen-users@xxxxxxxxxxxxxxxxxxx, xen-devel@xxxxxxxxxxxxxxxxxxx
  • From: "Hardeep Singh" <hardeepguru@xxxxxxxxx>
  • Date: Fri, 30 Jun 2006 11:21:33 -0500
  • Delivery-date: Fri, 30 Jun 2006 09:21:57 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; b=QLxCEBUFQAnNZ74udMjHypKvO029NMVi17GzUSUofhI5nMJrskRM3UnKkW+9BE5M5StcNIPRWY0fboGPzRF8Olo/7kcSdNOww0xkgRnZK1UPMwbkXOmuNaZStCwzf/CX/bIS/qPrSah/7cLU3+bhkoZLVyh2wK922RLpmQDi9Y8=
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

Yes, I have tried running that command 3 times and it has cropped up everytime!

And I have no idea what changesets are. I am pretty much a newbie to xen and after a long struggle did I manage to get xen-unstable working. I needed the credit scheduler for a part of my project. I had downloaded the tarball of xen-unstable yesterday and compiled it and on running the 'xm sched-credit -d vm1 -w 10' I got the error!

As for the sequence of commands.

- On one instance I ran 'xm sched-credit -d vm1' and that worked fine. It showed me the cap and weight of that domain. After that ''xm sched-credit -d vm1 -w 10'  gave an error.
- On another instance I directly ran 'xm sched-credit -d vm1 -w 10'  and got the same error

Please lemme kno if I need to update my unstable version and how to do it.

Hardeep Singh

On 6/30/06, Emmanuel Ackaouy <ack@xxxxxxxxxxxxx> wrote:
That's not a known issue. I'll take a look.

Is this easily reproduceable?
What changeset are you building?
What exact sequence of "xm sched-credit" commands are you
running to reproduce this?

On Fri, Jun 30, 2006 at 09:49:57AM -0500, Hardeep Singh wrote:
>    Hi,
>    Thanks a lot with regards to my previous postings. I did a line to line
>    comparison of the .config of the xen3.0 and xen-unstable and found the
>    appropriate disk driver required and managed to boot xen-unstable!
>    However, I need to run the credit scheduler. I am running xen-unstable on
>    ubuntu distribution on a 64bit architecture. Now when I issue xen the
>    following command I get an error as shown below. Can anyone provide any
>    pointers on how to fix this or whether there are any patches.
>    root@pippin:/home/hardeep# xm sched-credit -d vm1 -w 10
>    (XEN) BUG at sched_credit.c:757
>    (XEN) ----[ Xen-3.0-unstable    Not tainted ]----
>    (XEN) CPU:    0
>    (XEN) EIP:    e008:[<ff10fc00>] csched_tick+0x420/0x5a0
>    (XEN) EFLAGS: 00010096   CONTEXT: hypervisor
>    (XEN) eax: 00000000   ebx: 00000000   ecx: 0000000a   edx: 00000000
>    (XEN) esi: ff192080   edi: ff192e08   ebp: ff1646e1   esp: ff19df04
>    (XEN) cr0: 8005003b   cr3: 3e919000
>    (XEN) ds: e010   es: e010   fs: 0000   gs: 0000   ss: e010   cs: e008
>    (XEN) Xen stack trace from esp=ff19df04:
>    (XEN)    ff16419f ff1646e1 000002f5 ff12517b 00000000 ffffffff 00000246
>    ff192e00
>    (XEN)    0000001e 0000000a 00000000 00000000 00000000 ff1a5144 0000000a
>    00000000
>    (XEN)    ff192080 ff19dfb4 00000075 ff111ef2 00000000 00000005 00000002
>    ff1a6200
>    (XEN)    ff1a6200 ffbfed80 41438ac2 ff1140f6 00000000 cd123ee8 00000001
>    ff125317
>    (XEN)    ff17e080 00000000 ff1a7780 00000000 00007ff0 cee6f200 c058b030
>    ff112f12
>    (XEN)    00007ff0 cee6f200 ff192080 ff1535d6 cd123edc 00000001 00000000
>    00007ff0
>    (XEN)    cee6f200 c058b030 00000000 000e0004 c0101347 00000061 00000246
>    cd123ed8
>    (XEN)    00000069 0000007b 0000007b 00000000 00000000 00000000 ff192080
>    (XEN) Xen call trace:
>    (XEN)    [<ff10fc00>] csched_tick+0x420/0x5a0
>    (XEN)    [<ff12517b>] process_deferred_ops+0x9b/0x160
>    (XEN)    [<ff111ef2>] t_timer_fn+0x72/0xc0
>    (XEN)    [<ff1140f6>] timer_softirq_action+0xc6/0x120
>    (XEN)    [<ff125317>] do_update_va_mapping+0xd7/0x390
>    (XEN)    [<ff112f12>] do_softirq+0x32/0x50
>    (XEN)    [<ff1535d6>] process_softirqs+0x6/0x10
>    (XEN)
>    (XEN) ************************************
>    (XEN) CPU0 FATAL TRAP 6 (invalid opcode), ERROR_CODE 0000, IN INTERRUPT
>    (XEN) System shutting down -- need manual reset.
>    (XEN) ************************************
>    Regards,
>    Hardeep Singh

> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.