[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Fwd: compile error : make: *** i386-dm: No such file or directory.

  • To: "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>
  • From: "Anand Gupta" <xen.mails@xxxxxxxxx>
  • Date: Mon, 24 Jul 2006 03:32:59 +0530
  • Delivery-date: Sun, 23 Jul 2006 15:03:22 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:mime-version:content-type; b=AAQdJaBAwFbg93+kIYchgt+n/fEK2+xYy8cKTMm09DF1JFzCKnCTuaWeAHngoqznPeeBF609PCVJ/OG2hak74sndvgYXVYA/JPDUclRspaJVglHLwmV5Az6UevcCg1VsdajCIylwu1HU2GCR9XsUXJftfjBfRttLJHeowzwWUkU=
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

Can anyone help me with the error below ? Have tried with a fresh download using mercurial with the latest changeset still the same error. I get the same error if i do a make distclean.

Any help would be appreciated.

---------- Forwarded message ----------
From: Anand Gupta <xen.mails@xxxxxxxxx>
Date: Jul 23, 2006 2:04 AM
Subject: compile error
To: Xen Users <Xen-users@xxxxxxxxxxxxxxxxxxx>

I was trying to compile the latest unstable from mercurial on a dual xeon, however it started to give me strange errors. I am using the latest changeset.

Here is the last few lines of the make dist command.

copying build/scripts- 2.3/pygrub -> /home/xen/xen-unstable.hg/dist/install/usr/bin
changing mode of /home/xen/xen-unstable.hg/dist/install/usr/bin/pygrub to 755
make[2]: Leaving directory `/home/xen/xen-unstable.hg/tools/pygrub'
make ioemuinstall
make[2]: Entering directory `/home/xen/xen-unstable.hg/tools'
[ -f ioemu/config-host.h ] || \
(cd ioemu && sh configure --prefix=/usr)
make -C ioemu install
make[3]: Entering directory `/home/xen/xen- unstable.hg/tools/ioemu'
texi2html -monolithic -number qemu-doc.texi
texi2html -monolithic -number qemu-tech.texi
perl -w /home/xen/xen-unstable.hg/tools/ioemu/texi2pod.pl qemu-doc.texi qemu.pod
pod2man --section=1 --center=" " --release=" " qemu.pod > qemu.1
perl -w /home/xen/xen-unstable.hg/tools/ioemu/texi2pod.pl qemu-img.texi qemu-img.pod
pod2man --section=1 --center=" " --release=" " qemu-img.pod > qemu-img.1
for d in i386-dm; do \
make -C $d all || exit 1 ; \
make: *** i386-dm: No such file or directory.  Stop.
make: Entering an unknown directorymake: Leaving an unknown directorymake[3]: *** [all] Error 1
make[3]: Leaving directory `/home/xen/xen- unstable.hg/tools/ioemu'
make[2]: *** [ioemuinstall] Error 2
make[2]: Leaving directory `/home/xen/xen-unstable.hg/tools'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/home/xen/xen-unstable.hg/tools'
make: *** [install-tools] Error 2

Anyone has any ideas what could be causing this ?? The only thing i changed from default kernel settings was the processor type, from Pentium Pro to Xeon.

I am changing it back to Pro and will try giving it a shot. Meanwhile will appreciate if someone can point me to how to resolve this error.


Anand Gupta
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.