[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] [PATCH] Add RCU support into Xen - Repost


> -----Original Message-----
> From: Keir Fraser [mailto:Keir.Fraser@xxxxxxxxxxxx] 
> Sent: Thursday, February 01, 2007 10:02 AM
> To: Santos, Jose Renato G; xen-devel@xxxxxxxxxxxxxxxxxxx
> Cc: Turner, Yoshio; Jose Renato Santos; G John Janakiraman
> Subject: Re: [Xen-devel] [PATCH] Add RCU support into Xen - Repost
> On 30/1/07 22:46, "Santos, Jose Renato G" 
> <joserenato.santos@xxxxxx> wrote:
> >   That is a good idea, although I would prefer if we could 
> find better 
> > names for the rcu functions. Get/put may give the wrong impression 
> > that a reference counter is being incremented/decremented 
> which would 
> > not be the case. It could also give the wrong impression that the 
> > matching "put" could be invoked any time later which may 
> leave us with 
> > an invalid domain pointer (if the pointer is kept beyond 
> the current 
> > Xen invocation). What about 
> > "find_domain_rcu()"/"end_find_domain_rcu()" ?
> Find_domain_by_id_rcu()/end_domain_rcu()?
  Do we really need to have "by_id" on the name? Isn't find_domain_rcu()
clear enough?
  After all, from the function definition it should be clear that it
takes a domid as parameter.
  I like end_domain_rcu().
>  -- Keir

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.