[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: c/s 14420 (gcc 3.4+ required)

>>> "Jan Beulich" <jbeulich@xxxxxxxxxx> 19.03.07 13:36 >>>
>>>> Keir Fraser <keir@xxxxxxxxxxxxx> 19.03.07 10:51 >>>
>>On 19/3/07 09:35, "Jan Beulich" <jbeulich@xxxxxxxxxx> wrote:
>>> what are the exact issues that required this change? SLES9 being based on
>>> gcc 3.3.3 makes it pretty undesirable for me/us to have this kind of a
>>> requirement. Despite me certainly being able to compile newer gcc-s (I
>>> actually have these around all the time), the mere fact to remember to pass
>>> a CC= each time I want to build Xen is going to make this cumbersome.
>>> Hence I'd like to understand the underlying issue(s), see whether they apply
>>> to the 3.3.x versions we have in use (aside of SLES9 I also continue to have
>>> one 9.0 system around that I use for regular building and testing).
>>It's fine to build Xenolinux with older gcc versions. The new constraint is
>>just for the hypervisor itself, plus the toolstack. The issue is that all
>>gcc 3.3.x miscompile alignment attributes hidden inside typedefs, which we
>>were having to work around. It's not a big issue (the workaround in this
>>case is small), but gcc 3.4.0 has been available now for three years, and I
>>wouldn't recommend anyone to run a distro as old as SLES9 as their dom0
>I just scanned the tree and couldn't spot any such instance. Could you point
>me to one?

Okay, sorry, I found one - I had skipped the public headers, as I assumed you
wouldn't change those, forgetting about the few __XEN__/__XEN_TOOLS__
conditionals in there.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.