[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: [PATCH][HVM] pass-through PCI device hotplug support

  • To: "Zhai, Edwin" <edwin.zhai@xxxxxxxxx>
  • From: Keir Fraser <Keir.Fraser@xxxxxxxxxxxx>
  • Date: Sun, 17 Feb 2008 16:43:27 +0000
  • Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Sun, 17 Feb 2008 08:42:58 -0800
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>
  • Thread-index: AchxhDgMdpM+1t13EdydtAAWy6hiGQ==
  • Thread-topic: [PATCH][HVM] pass-through PCI device hotplug support

On 17/2/08 15:34, "Zhai, Edwin" <edwin.zhai@xxxxxxxxx> wrote:

>> passthrough.c, so the former can cleanly build without the latter. I also
>> killed pt_uninit() because I couldn't even find where pci_cleanup() was
> pci_cleanup() is in the libpci, which should be called for clean up in theory.
> But things goes well without it.

Well, you can add it back in then.

>> defined. No passthrough function should be in vl.c: I #ifdef'ed in the for
> Our plan is making this hotplug generic besides passthough device, even for
> virtual PCI device on native QEMU. So leaving do_pci_add/del in vl.c should be
> okay like do_usb_xxx.

Isn't there a generic pci source file where they might more sensibly belong?

 -- Keir

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.