[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Re: pv_ops dom0 USB fixed

Todd Deshane wrote:
That's because your initramfs only contains modules for
2.6.27-7-generic but your Xen kernel is 2.6.28-rc8-tip so the ramdisk
fails to load the modules it needs.

Yeah, I figured that out this morning as well (Sorry for the silly mistake
and noise previously).

I have 3 new logs though, that may give some more information
into the detection of the USB disk as well as others.

Still not booting, but it looks like it *should* work.

The first shows that it clearly detects the usb disk, but as
sda{1}, which makes some sense since it doesn't detect
the other two SCSI disks. Also it detects it late...

So, I then changed the root to sda1 and added a rootdelay
option (twice I tried to add rootdelay, the second one I
put up to 90 seconds even.

I don't know if they shed any light or if there is something
obvious that I could do to fix the situation.

So I've been getting things going on my test box here.  What I've observed:

When I set the SATA controller to either "Legacy" mode or "Native / IDE" mode in the BIOS, it works fine.

When I set it to AHCI, I see the same timeouts on IDENTIFY, but the DVD drive is detected properly.

USB seems to be working fine. If I plug in a memory stick, I can mount the filesystem and read things from it.

In these logs, it looks like you've overlooked the patch I added on Friday (vmap-allow-unflush-tlb.patch), and your udevd processes have been caught up in a deadlock which is preventing them from doing their thing. I suspect that's the root cause of your problems.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.