[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] virbr0/bridge: No such file or directory, rhel6 bridge-utils IGMP snooping


> > > - do you have ip_forwarding (routing) enabled in dom0?
> > 
> > No. That was not mentioned or required according to your tutorial.
> > 
> NAT requires ip_forwarding/routing! This is a generic requirement for all 
> Linux NAT stuff,
> be it Xen or something else.

I am using i686 arch system, NOT x86_64. Did you try your tutorial on a i686 
system and worked? Were you able to add DomU successfully?


Do you mind telling me how to set ip_forwarding? What file and what variable?




> > > - How are your firewall rules in dom0?
> > 
> > 
> > Disabled
> > 
> Then it obviously won't work!
> When dnsmasq starts it should add the firewall rules for NAT.

I thought, SElinux must be disabled. In addition, I can not use DHCP in our 
network. I am using ststic IPs.




> > > - Is dnsmasq running?
> > No, dsnmasq was not running. I started dnsmasq, but didn't solve the 
> > problem.
> > 
> dnsmasq acts as a dhcp server and DNS server for virbr0 bridge, 
> so you definitely need it running!

Again, I am not using and I can't use DHCP in our network. I am using static 
IPs. Do I still need dnsmasq?




> > > - Do you see domU dhcp requests in system logs (from dnsmasq) ?
> > 
> > 
> > No. I always set dhcp off. I use static ips.
> > 
> What IP did you configure in the VM? 
> Could you ping the gateway (dom0 IP on virbr0) from the VM?

Let's say, I am using as a server main IP. When I create a DomU 
and go through installation screens, I use a unique/different IP as a main IP 
for the domain, our network gateway IP and MASK, and another unique IP for our 
Nameserver. Does this make sense? This is what I did on Xen v3.x and it worked 
just fine.



> > > - After the domU is started run "brctl show" - is the domU vif connected 
> > > to virbr0 bridge?
> > 
> > 
> > It showed:
> > 
> > bridge name bridge id STP enabled interfaces
> > virbr0 8000.feffffffffff yes
> > 
> So the VM is NOT connected to virbr0 at all!
> Do you have xen-netback driver loaded in dom0 kernel?

How can I check on that? By the way, following your tutorial with a slight 
change, I am using i686 machine; I ran these commands to install Dom0:


git clone git://git.kernel.org/pub/scm/linux/kernel/git/jeremy/xen.git 
cd linux-2.6-xen
git checkout -b xen/stable-2.6.32.x origin/xen/stable-2.6.32.x


wget -O .config 
make oldconfig
make -j4 bzImage && make -j4 modules && make modules_install



> > > - Run "tcpdump -i virbr0 -nn" - do you see the traffic from the vm?
> Did tcpdump show any traffic?
> > > - Does the domU get an IP? 
> > 
> > Nope.
> > 
> > Why Xen v4.x is so buggy and difficult to deal with? I didn't have these 
> > problems using version 3.x. Does that mean v4 in still in beta?
> > 
> 4.x is not in beta. 
> When building a platform on your own, you need to understand
> how things work and configure everything properly.

Sure. By the same token, the system, any system, doesn't have to complicated to 
configure. Any system should be fairly easy, even for a newbie, to install and 
configure. Do we agree on that?


Thank you and I really appreciate your help.                                    
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.