[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Help with the migration to XEN-4.1 please

On Tue, 2011-09-13 at 04:58 -0400, Flavio wrote:
> Hello,
> I recently installed XEN on my Gentoo Linux that I use mainly as a
> Desktop and I had to switch from xm to xl tool stack.
> Since also the gentoo-sources support XEN natively I installed XEN on
> my Desktop
> distribution too. Well, I started installing XEN as usual, and I was
> using it only with the xm tool stack.
> Now I read about the migration to the new toolstack at
> http://wiki.xensource.com/xenwiki/MigrationGuideToXen4.1%2B but
> I have some problem and some question to do.
> First of all, let me list my environment:
> OS: Gentoo Linux 10.0 kernel: gentoo-sources-3.0.4 arch x86_64
> app-emulation/xen-4.1.1-r1
> app-emulation/xen-tools-4.1.1-r3 with USE flags: "hvm ioemu"
> I also completed the following checklist:
> - Configure your host networking using the configuration tools
> provided by your distribution.
> - Remove any python code from domU configuration files.
> - Disable xend startup script (it doesn't exist anymore)
> - Use xl command instead of xm (xm doesn't exist anymore)
> 1) Now the xend initscript has been removed. Well, I had some domain
> registered with the command 'xm new vm_name.cfg'.
> Actually, performing a "xm list" it was showing them in the list of
> the domains after the dom0.
> Now that xend has been removed, it is no longer running and 'xl list'
> doesn't show any domU in the list. How does it work now?

I'm afraid that xl does not support this style of "managed" domain.
The /etc/xen/auto type stuff ought to still work although there have
been a bunch of fixes to that recently, I think they are all queued for
4.1.2 but it might be worth confirming that tools/hotplug in your tree
looks similar to that in xen-unstable.hg

> I tried to put the vm configuration file in /etc/xen/auto but in this
> way it starts the vm and not simply it adds to the xen domain store,
> letting me decide if starting the vm or not. I was looking for the
> analogue command as "xm new config_file.cfg" in xl if exists.
> 2) If I try to run a gentoo linux guest (for instance) running
> 'xl vm_config_file.cfg -c' I get the following error:

You mean 'xl create vm_config....'?

> xenconsole: Could not read tty from store: No such file or directory
> But the vm starts even if the networking doesn't work now, of course.
> I've already searched and found several results on Google but the
> problem is still there. :(

Did you start xenstored and xenconsoled? i.e. did you add the
"xencommons" initscript to your startup?

> 3) the network for the guest OS doesn't work, even the xenbr0 is up
> and the vm configuration file
> explicitly says it has to use that bridge. Furthermore, due to the
> error at point 2, I can't see anything
> in the VM.
> I also tried to add the following line in the /etc/xen/xl.conf but the
> network doesn't work anyway:
> vifscript="vif-bridge"

> 4) xl shutdown <domain_number> seems to be not working. I have to
> destroy the VM in order to have it powered off.
> Can somebody help me to correct these problems please?

Both of these sound as if xenstored is not working properly for you. Is
it running? You didn't restart it did you? (you cannot restart
xenstored, unfortunately if you did this you need to reboot).

Did you also change kernel when you moved to 4.1? Do you have
the /dev/xen nodes, especially evtchn loaded and available? With pvops
many kernels are more standard distro kernels rather than xen-specific
and therefore stuff which was historically statically built in to the
kernel are now modular.

> --
> Flavio
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-devel

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.