[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Issues with Intel HD graphics 4000

  • To: xen-devel@xxxxxxxxxxxxx
  • From: Dietmar Hahn <dietmar.hahn@xxxxxxxxxxxxxx>
  • Date: Mon, 17 Jun 2013 09:04:31 +0200
  • Cc: Andrew Bobulsky <rulerof@xxxxxxxxx>, Joshua Tuttle <jtuttle@xxxxxxxxx>
  • Delivery-date: Mon, 17 Jun 2013 07:05:26 +0000
  • Domainkey-signature: s=s1536a; d=ts.fujitsu.com; c=nofws; q=dns; h=X-SBRSScore:X-IronPort-AV:Received:X-IronPort-AV: Received:Received:From:To:Cc:Subject:Date:Message-ID: User-Agent:In-Reply-To:References:MIME-Version: Content-Transfer-Encoding:Content-Type; b=nH60K41hHlGlFuEpyMSfEyXFJn30txQ563xawJiHHc9z5pGSyPwM06Yz XDWehq+FBJLn2di6NrV8+rRRR4tQJN+/gfd/g6ye0rgpGLm5Ncrc1kyUk OrUXkrugxpmOhhcn4w9j659m3sSNBL3toyyOeIMnY84cwNT8ucjb5hxkZ nrtQqtArW6qNUwnDYq3yvaIdeRmaiILQwm8sORYKCduIvkL+zs5CDgbuB 490iHRN/sALkohwy/5Sg3TKozsVJX;
  • List-id: Xen developer discussion <xen-devel.lists.xen.org>

Am Freitag 14 Juni 2013, 20:30:25 schrieb Andrew Bobulsky:
> On Fri, Jun 14, 2013 at 3:46 PM, Joshua Tuttle <jtuttle@xxxxxxxxx> wrote:

> > Are there any known issues with the Intel’s integrated HD graphics 4000? I
> > just bought a new laptop and have tried everything I can think of to get Xen
> > to load. After choosing Xen in GRUB, it just boots to a black screen. There
> > is no error message , no dmesg output, nothing. I have no idea what is
> > causing this problem. I’ve gotten Xen to install with no problems on another
> > machine that has an nvidia geforce 210. I’ve tried different boot parameters
> > as well to try and default to the linux vga driver instead of trying to use
> > the intel one. My linux debian distro, has no problem booting though.

Can you add the iommu=off on the Xen command line.
Maybe it's a similar problem I had with newer linux kernels:

> >
> > Thanks for any help,
> >
> > Josh
> Hello Josh,
> I had the same problem with both my Radeon *and* my HD 4000.
> Switching to kernel 3.4.44 worked, and I haven't dived back into the

Yes, kernel-xen-3.4.45 on openSuSE runs without any problems.

> problem since.  YMMV of course, but just a suggestion in case you
> don't hear from anyone else; weekends are slow on mailing lists
> sometimes :)
> Cheers,
> Andrew

Company details: http://ts.fujitsu.com/imprint.html

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.