[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [Fedora-xen] Virt-manager does not connect to libvirt/Xen? Xen 4.1.5 installed from source on Fedora 17.

Thanks for replying Dario,

Yes, I saw your other e-mail too, but I'm afraid I can't help much as I
always have:
Â- used xl only, when building Xen from sources,
Â- used Fedora Xen packages only, when using libvirt stuff

I just want to get couple of DomUs running, that is all. I'm not particular about which tool I use.
Virt-manager seemed easier/quicker, hence I picked that.

I did some reading on configuring DomUs using xl/xm and cfg files.

So basically I create the cfg file, and do "xm/xl create xmf16install -c"
This is one of my cfg files.

vif = [ 'bridge=br0' ]
kernel = "/home/fedora16pxe/vmlinuz"
ramdisk = "/home/fedora16pxe/initrd.img"

The CentOS/Fedora installers are being launched, but I think I am running into a problem when the installers ask for HTTP location from where to pickup the images for install. I got different kinds of errors each time (I tried multiple installations (F15,16, F17, CentOS5).Â

Some of the errors I got from the anaconda installers wereÂ
(F12, CentOS5)
'' loader received SIGSEGV! ÂBacktrace: Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â Â ÂÂ
install exited abnormally [1/1]Â
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
/proc done
/dev/pts done
/sys done
/tmp/ramfs done
you may safely reboot your system"Â

"Unable to read package metadata. This may be due to a missing  Ââ
   â repodata directory. ÂPlease ensure that your install tree has  Ââ
   â been correctly generated.                    Ââ
   â                                 Ââ
   â Cannot retrieve repository metadata (repomd.xml) for repository: â
   â updates. Please verify its path and try again Â"

I am guessing there is a problem when it tries to connect to the internet to download packages.Â
I have also attached my domU cfg file for reference in the email.Â

Could someone point out where am I going wrong ?

I just want to get couple of DomUs working and this is proving tougher than I thought. :(
Is there something wrong with my cfg files. Or is something else the issue here ?

I see... Just shooting in the dark here, and forgive me if it's a stupid
question, but is libvirtd running?

Yes, it is.Â
# service libvirtd status
libvirtd.service - Virtualization daemon
ÂLoaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled)
ÂActive: active (running) since Thu, 20 Jun 2013 09:50:10 -0500
Main PID: 1248 (libvirtd)
ÂCGroup: name=systemd:/system/libvirtd.service

As I said, I'm really short in ideas/experience, sorry. Something I
would probably try is:
Â- uninstalling your built version of Xen
Â- installing Fedora 17's Xen packages
Â- try libvirt with them

This was what I tried initially. Regular F17, then yum install Xen, and Virt-manager just worked out of the box for me, and I was able to create DomUs.Â
Sorry, I just seem to be running into multiple issues with this! Kindly help.Â
Any pointers would be greatly appreciated.

If all else fails, I am willing to start with a fresh install of F18 as Dom0 and try to install Xen from source on that. Would this help ? I remember you telling me F18 with Xen 4.2 working well with the Virt-tools.Â

Ranjith krishnan
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.