[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [Fedora-xen] Virt-manager does not connect to libvirt/Xen? Xen 4.1.5 installed from source on Fedora 17.

On gio, 2013-06-20 at 05:32 -0500, ranjith krishnan wrote:
> Thanks for replying Dario,
>         Yes, I saw your other e-mail too, but I'm afraid I can't help
>         much as I
>         always have:
>          - used xl only, when building Xen from sources,
>          - used Fedora Xen packages only, when using libvirt stuff
> I just want to get couple of DomUs running, that is all. I'm not
> particular about which tool I use.
Mmm... So you do not need any specific/unpackaged version of Xen, or you
don't need to modify Xen's code or apply any specific patch to it? If
no, why bothering with building from sources?

If you don't need anything particular, using what the distro provides is
almost always waaay easier than building from scratch, and that is
_especially_ true for Xen! :-O

> Virt-manager seemed easier/quicker, hence I picked that.
Sure it is, but you seem to be adding unnecessary complications to the
whole process, by trying building Xen yourself.

> I did some reading on configuring DomUs using xl/xm and cfg files.
> http://www.fclose.com/b/linux/2544/setting-up-lvm-backed-xen-domu/
> http://www.fclose.com/w/Setting_Up_Xen_DomU_on_Fedora:_Unmodified_Fedora_on_Top_of_Xenified_Fedora_Xen_Dom0%23Install_Fedora_12_Linux_via_Internet
> So basically I create the cfg file, and do "xm/xl create xmf16install
> -c"
> This is one of my cfg files.
> name="xmf16install"
> memory=2048
> vcpus=1
> disk=['phy:/dev/xenvg/xmf16lvm,xvda,w']
> vif = [ 'bridge=br0' ]
> kernel = "/home/fedora16pxe/vmlinuz"
> ramdisk = "/home/fedora16pxe/initrd.img"
> onreboot = 'restart'
> oncrash = 'restart'
I don't see anything bad here (although, I use different ways for
installing guests, so I can't be sure).

> The CentOS/Fedora installers are being launched, but I think I am
> running into a problem when the installers ask for HTTP location from
> where to pickup the images for install. I got different kinds of
> errors each time (I tried multiple installations (F15,16, F17,
> CentOS5). 
I see but, as you said, the Xen side of the thing appears to be working
(you see the installers!). There might be other issues, but I've no clue
about them I'm afraid.

> I am guessing there is a problem when it tries to connect to the
> internet to download packages. 
Could be... Is the bridge working?

> I just want to get couple of DomUs working and this is proving tougher
> than I thought. :(
Well, I'm not saying it's always piece of cake, but when you decide to
build your own Xen instead of using what the distro gives you, you
committed 'voluntary manslaughter' against simplicity yourself! :-P

>         As I said, I'm really short in ideas/experience, sorry.
>         Something I
>         would probably try is:
>          - uninstalling your built version of Xen
>          - installing Fedora 17's Xen packages
>          - try libvirt with them
> This was what I tried initially. Regular F17, then yum install Xen,
> and Virt-manager just worked out of the box for me, and I was able to
> create DomUs. 
No, I'm sorry, but now I feel like I'm loosing you. Are you saying that
you installed Xen and virt-* with yum and you add it all working fine?
Well, if yes, why you abandoned that path?

> Sorry, I just seem to be running into multiple issues with this!
> Kindly help. 
> Any pointers would be greatly appreciated.
There's no need to be sorry, although I'm not sure I can see what is
happening and provide useful directions. At least nothing different from
_try_official_packages_, especially if you said that they were working.

> If all else fails, I am willing to start with a fresh install of F18
> as Dom0 and try to install Xen from source on that. Would this help ?
> I remember you telling me F18 with Xen 4.2 working well with the
> Virt-tools. 
Again, and sorry for repeating myself, if you do this, _do_ install an
F18 (actually, at this time, you may want to go for F19) and _do_
install both Xen, libvirt and the libvirt tools with *yum*. Don't build
anything if you don't need it. :-)

I said, and I confirm here, that on Fedora 18 (and the same applies to
F19 Beta, at least the few times I tired) I have virt-manager and
virt-install working well, either with xend running (i.e., using the old
toolstack and the xen libvirt driver) or without xend (i.e., using the
new toolstack and the libxl libvirt driver), at least for basic
create/start/pause/suspend/resume/reboot/shutdown workflow.


<<This happens because I choose it to happen!>> (Raistlin Majere)
Dario Faggioli, Ph.D, http://about.me/dario.faggioli
Senior Software Engineer, Citrix Systems R&D Ltd., Cambridge (UK)

Attachment: signature.asc
Description: This is a digitally signed message part

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.