[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [Fedora-xen] Virt-manager does not connect to libvirt/Xen? Xen 4.1.5 installed from source on Fedora 17.

Mmm... So you do not need any specific/unpackaged version of Xen, or you
don't need to modify Xen's code or apply any specific patch to it? If
no, why bothering with building from sources?

If you don't need anything particular, using what the distro provides is
almost always waaay easier than building from scratch, and that is
_especially_ true for Xen! :-O

I am a graduate student, and this is for my final project. 
My intention is to make some code changes in Xen and try some things out, once I get DomUs working.
That is why I am trying to install from source. 

> I am guessing there is a problem when it tries to connect to the
> internet to download packages.
Could be... Is the bridge working?

brctl shows me this. Does this mean everything is OK with the bridge ?
# brctl show
bridge name bridge id STP enabled interfaces
br0 8000.001ec936a1c5 no em1
virbr0 8000.525400f132d7 yes virbr0-nic

> This was what I tried initially. Regular F17, then yum install Xen,
> and Virt-manager just worked out of the box for me, and I was able to
> create DomUs.
No, I'm sorry, but now I feel like I'm loosing you. Are you saying that
you installed Xen and virt-* with yum and you add it all working fine?
Well, if yes, why you abandoned that path?

Since I am new to Xen, I tried the official packages (yum install, virt-manager) just to get some familiarity and confidence working with the system. I thought once I have those working I can install from source and make changes.

Again, and sorry for repeating myself, if you do this, _do_ install an
F18 (actually, at this time, you may want to go for F19) and _do_
install both Xen, libvirt and the libvirt tools with *yum*. Don't build
anything if you don't need it. :-)

I said, and I confirm here, that on Fedora 18 (and the same applies to
F19 Beta, at least the few times I tired) I have virt-manager and
virt-install working well, either with xend running (i.e., using the old
toolstack and the xen libvirt driver) or without xend (i.e., using the
new toolstack and the libxl libvirt driver), at least for basic
create/start/pause/suspend/resume/reboot/shutdown workflow.

 Ok. I will try F18 next time. But I want to keep that as my last resort, if nothing else works.

Right now, I thought I can download the iso file for fedora, save the image on to the hard disk and then use it to build the DomU with xl. If that doesnt work, I will look towards F18.

Ranjith krishnan
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.