[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [BUG] Bugs during building 4.3.1

Hi Andrew,


Thanks for the quick response and the notes!


See below.


Best regards,




From: Andrew Cooper [mailto:andrew.cooper3@xxxxxxxxxx]
Sent: Sunday, November 03, 2013 1:25 PM
To: David Denny
Cc: xen-devel@xxxxxxxxxxxxx
Subject: Re: [Xen-devel] [BUG] Bugs during building 4.3.1


On 03/11/13 18:02, David Denny wrote:



Thanks for the great software!  I use it constantly.  Thought I’d let you know of a few issues I ran into.  #3 might be pretty easy to fix.


1.       No spaces allowed in the base directory path!   I guess some quotes are missing on variables in the makefiles.  At least this is a “known limitation.”

Spaces in paths are generally frowned upon.  Having said that, it is probably something worth fixing if you can identify what is at fault.

> Agreed re: spaces, but with SAMBA continuing to come on string, it’s not likely to go away!   I’ll look in to it and see what I can find.  I have a suspicion that it may run throughout all the make process, and fixing it might seriously destabilize thing!  Having said that, it might be worth a note tucked away somewhere.  Perhaps I should follow that up with the documentation folks.


2.       Configuration process does not check for openssl and x11, which I believe are both required.

How are you building qemu upstream?  It is certainly not expected to be used with x11 enabled.  If you are using the defaults as present in Xen 4.3.1 then we really do have some fixing to do.

> I’m have no idea how I wound up with x11 and qemu enabled.  Frankly, I’m a bit of newbie on all the various options and such (hence the fooling around with Xen.)  It “just happened” and I was trying to satisfy the dependencies.  I had a heck of a time with 4.3.0 but this has gone quite smoothly!


This is how I ran configure.  It compiled well and then hit a snag with missing –lcrypt.  After patching that one, it later missed -lX11.


./configure --prefix=/opt/xen-4.3.1 \

  APPEND_LIB='/opt/openssl/lib /usr/x11/lib' \

  APPEND_INCLUDES='/opt/openssl/include /usr/x11/include' 2>&1


I’ve attached a log of the “bad” configure and build (the configure ran fine.)  I can also forward one of the “good” build.


3.       APPEND_LIB doesn’t carry through to all the makefiles.

This looks plausible.  If I remember correctly, the idea was always to fault in APPEND_LIB to new bits of the build system as and when needed.  I suppose you have come across this because of x11 and openssl ?

To submit patches, you should follow the instructions at http://wiki.xen.org/wiki/Submitting_Xen_Patches - particularity "Signing off a patch"

Ø    I read the notes – pretty straightforward and sensible. 

Ø    The third patch is not ready to go.  I just literally hacked in my paths to make it work. APPEND_LDFLAGS is not getting passed down to it.  I think a config file should

Ø    be included from a top-level directory, but I’ve tried putting in $(XEN_ROOT)/Config.mk and that didn’t help.  I would need to have some guidance to figure this one

Ø    out, hence submitting it as a “bug” not a “patch.”   Here is what it looks like…


“seccomp support   no

coroutine backend ucontext

GlusterFS support no

make[3]: Entering directory `/usr/src/3rd-Party/Xen/xen-4.3.1/tools/qemu-xen-dir'

  GEN   config-host.h

  GEN   trace.h

  GEN   trace.c

  GEN   trace.c

  GEN   config-target.h

  LINK  i386-softmmu/qemu-system-i386

/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.1/../../../../x86_64-unknown-linux-gnu/bin/ld: cannot find -lX11

collect2: error: ld returned 1 exit status

make[4]: *** [qemu-system-i386] Error 1

make[3]: *** [subdir-i386-softmmu] Error 2

make[3]: Leaving directory `/usr/src/3rd-Party/Xen/xen-4.3.1/tools/qemu-xen-dir'

make[2]: *** [subdir-all-qemu-xen-dir] Error 2

make[2]: Leaving directory `/usr/src/3rd-Party/Xen/xen-4.3.1/tools'

make[1]: *** [subdirs-install] Error 2

make[1]: Leaving directory `/usr/src/3rd-Party/Xen/xen-4.3.1/tools'

make: *** [install-tools] Error 2”




My openssl and x11 libraries are in non-standard locations (not in /usr/X11 or /usr/openssl).

I’ve provided three very trivial patches that I hope will be more illustrative than my typing, but they are probably not production grade. 

I applied them prior to configuration and got a clean build.


Best regards,



Xen-devel mailing list


Attachment: configure.log
Description: Binary data

Attachment: make.log.gz
Description: GNU Zip compressed data

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.