[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v14 04/17] Introduce pv guest type and has_hvm_container macros

On 04/11/13 16:20, Jan Beulich wrote:
On 04.11.13 at 13:14, George Dunlap <george.dunlap@xxxxxxxxxxxxx> wrote:
The goal of this patch is to classify conditionals more clearly, as to
whether they relate to pv guests, hvm-only guests, or guests with an
"hvm container" (which will eventually include PVH).

This patch introduces an enum for guest type, as well as two new macros
for switching behavior on and off: is_pv_* and has_hvm_container_*.  At the
moment is_pv_* <=> !has_hvm_container_*.  The purpose of having two is that
it seems to me different to take a path because something does *not* have PV
structures as to take a path because it *does* have HVM structures, even if
two happen to coincide 100% at the moment.  The exact usage is occasionally
a bit
fuzzy though, and a judgement call just needs to be made on which is

In general, a switch should use is_pv_* (or !is_pv_*) if the code in
relates directly to a PV guest.  Examples include use of pv_vcpu structs or
other behavior directly related to PV domains.

hvm_container is more of a fuzzy concept, but in general:
So sadly this is still being retained, despite its redundancy.


Given that the long-term plan is to get rid of the extra mode entirely (at which point has_hvm_container will also go away), are you OK with this patchset going in as it is?

There are a lot of individual places to change, and I'm a bit afraid that a large change like that will introduce some bugs I'll have to spend more time tracking down... I'd rather just do all the changes when we get rid of the extra mode, if possible.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.