[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH OPW 05/11] libxl: use LOGE instead of LIBXL__LOG_ERRNO in libxl_utils.c



On Mon, Nov 11, 2013 at 03:23:54PM -0800, Kelley Nielsen wrote:
> Code cleanup - no functional changes
> 
> The convenience macro LOGE has been written to take the place of
> LIBXL__LOG_ERRNO. LOGE depends on the existence of a local libgl__gc
> *gc. Replace two invocations of LIBXL__LOG_ERRNO, which are in
> functions that already have a libxl__gc *gc present, to invocations
> of the new macro.
> 
> Suggested-by: Ian Campbell <Ian.Campbell@xxxxxxxxxx>
> Signed-off-by: Kelley Nielsen <kelleynnn@xxxxxxxxx>
> ---
>  tools/libxl/libxl_utils.c | 11 +++++------
>  1 file changed, 5 insertions(+), 6 deletions(-)
> 
> diff --git a/tools/libxl/libxl_utils.c b/tools/libxl/libxl_utils.c
> index 53ebf73..ca3406b 100644
> --- a/tools/libxl/libxl_utils.c
> +++ b/tools/libxl/libxl_utils.c
> @@ -207,15 +207,14 @@ out:
>  
>  static int logrename(libxl__gc *gc, const char *old, const char *new)
>  {
> -    libxl_ctx *ctx = libxl__gc_owner(gc);
>      int r;
>  
>      r = rename(old, new);
>      if (r) {
>          if (errno == ENOENT) return 0; /* ok */
>  
> -        LIBXL__LOG_ERRNO(ctx, LIBXL__LOG_ERROR, "failed to rotate logfile - 
> could not"
> -                     " rename %s to %s", old, new);
> +        LOGE(ERROR, "failed to rotate logfile - "
> +          "could not rename %s to %s", old, new);

You are introducing TABs here.

>          return ERROR_FAIL;
>      }
>      return 0;
> @@ -248,9 +247,9 @@ int libxl_create_logfile(libxl_ctx *ctx, const char 
> *name, char **full_name)
>              goto out;
>      } else {
>          if (errno != ENOENT)
> -            LIBXL__LOG_ERRNO(ctx, LIBXL__LOG_WARNING, "problem checking 
> existence of"
> -                         " logfile %s, which might have needed to be 
> rotated",
> -                         name);
> +            LOGE(WARN, "problem checking existence of logfile %s, "
> +              "which might have needed to be rotated",

Same here.

> +                 name);
>      }
>      *full_name = strdup(logfile);
>      rc = 0;

Once the TABs are replaced:
Reviewed-by: Anthony PERARD <anthony.perard@xxxxxxxxxx>

-- 
Anthony PERARD

_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
http://lists.xen.org/xen-devel


 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.