[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen on ARM basic questions

On Fri, 2013-11-22 at 14:20 -0500, Vaibhav Bedia wrote:
> >> >> Right now i have an OMAP5 dom0 with network+usb support and i am
> >> >> trying to figure out how to get these things in domU and hence the
> >> >> questions.
> >> >
> >> > You need blkback and netback in dom0 and blkfront and netfront in domU
> >> > (all in mainline Linux). Then you need to add vif and disk options to
> >> > your guest configuration.
> >> >
> >>
> >> I enabled both of the options and can get a ramdisk based domU running 
> >> fine.
> >> I tried a Ubuntu based fs for domU but can't get to the login prompt
> >> for some reason.
> >> I tried out the various options mentioned @
> >> http://wiki.xen.org/wiki/Xen_Common_Problems#Console
> >> and some other things mentioned on various forums but nothing seems to 
> >> work :(
> >> Any hints on where things could be going wrong? I have hvc0.conf under
> >> /etc/init/
> >
> > Do you have CONFIG_HVC_XEN enabled in the guest kernel config? Is the
> > guest detecting that it is running under Xen? Can you post a guest dmesg
> > please.
> >
> Yes. It's enabled. I can get the same image to the login prompt using a 
> minimal
> ramdisk so it should be something to do with the Ubuntu filesystem, right?

You may need to configure Ubuntu to start a getty on hvc0 (the console
device). This involves adding an upstart configuration file, copying an
existing tty one and changing the device I guess? I don't know the
details. Hopefully there's enough keywords there to let you do a search.

Oh, I see further back in the thread that you have this. I'm afraid I
don't know enough about Ubuntu to diagnose what may be going wrong.
Perhaps post your hvc.conf and maybe someone can spot what is going

> The IP address is via DHCP. Once i get the login prompt using the
> minimal ramdisk i run
> $ ifconfig eth0 up
> <eth0 mac address is what i assign in the config file>
> $ udhcpc
> Guest gets an IP address now.

Do you know where the DHCP server is? It is worth checking the logs in
case udhcpc has actually failed and used a previously successful lease
which it has cached. I don't know about udhcpc but other DHCP clients
tend to log when they do this.

> The above sequence doesn't work always but when it does get an IP
> address i can't
> ping domU or have it ping some other host. I didn't setup any firewall
> explicitly - just
> using plain ubuntu 13.04.

I don't know if Ubuntu ships with a firewall enabled or not -- you
should certainly confirm!

> I do see that the vif is added to the bridge.

In "brctl show" I suppose?

>  I also noticed that the
> errrors under eth0
> starts going up when i create a guest and eventually the network in dom0 
> becomes
> completely unresponsive.

That's quite, er, interesting. I've never heard of that before.

I see you have two vifs, are they on the same bridge? Do they have
different mac addresses?

Can you post your guest cfg file please.

I'd suggest taking the second vif out and working to get a single one
working, just to eliminate variables etc.

> P.S. Apologies for the flood of seemingly random datapoints.
> As you can see i am right now a total newbie to xen and trying to find
> my way around :)

That's ok. I'm a bit perplexed to be honest...

> =================
> Guest bootlog with Ubuntu fs:
> ===
> root@arm:~# xl console domU-xen
> [    0.000000] Booting Linux on physical CPU 0x0
> [    0.000000] Linux version 3.12.0-01110-g0c72f67-dirty
> (vaibhav@vaibhav-VirtualBox) (gcc version 4.7.3 (Ubuntu/Linaro
> 4.7.3-1ubuntu1) ) #13
> [    0.000000] CPU: ARMv7 Processor [412fc0f2] revision 2 (ARMv7), cr=10c5387d
> [    0.000000] CPU: PIPT / VIPT nonaliasing data cache, PIPT instruction cache
> [    0.000000] Machine: Dummy Virtual Machine, model: XENVM-4.2
> [    0.000000] cma: CMA: reserved 16 MiB at 87000000
> [    0.000000] Memory policy: ECC disabled, Data cache writealloc
> [    0.000000] PERCPU: Embedded 9 pages/cpu @c0ff4000 s15232 r8192 d13440 
> u36864
> [    0.000000] Built 1 zonelists in Zone order, mobility grouping on.
> Total pages: 32512
> [    0.000000] Kernel command line: console=hvc0 root=/dev/xvda
> mem=128M xencons=tty

How much mem did you give the guest in its configuration file? What
about in the DTB? I'd recommend leaving off this instance of mem= for

> [    4.074520] console [hvc0] enabled


> [    4.587776] blkfront: xvda: flush diskcache: enabled; persistent
> grants: enabled; indirect descriptors: enabled;
> [    4.600643]  xvda: unknown partition table
> [    4.742512] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
> [    4.754670] EXT3-fs (xvda): error: couldn't mount because of
> unsupported optional features (240)
> [    4.764590] EXT2-fs (xvda): error: couldn't mount because of
> unsupported optional features (244)
> [    4.775433] EXT4-fs (xvda): INFO: recovery required on readonly filesystem
> [    4.781320] EXT4-fs (xvda): write access will be enabled during recovery
> [    4.850791] EXT4-fs (xvda): recovery complete
> [    4.859316] EXT4-fs (xvda): mounted filesystem with ordered data
> mode. Opts: (null)
> [    4.865305] VFS: Mounted root (ext4 filesystem) readonly on device 202:0.


> [    4.869323] devtmpfs: mounted
> [    4.875165] Freeing unused kernel memory: 412K (c0877000 - c08de000)

This is the point at which I would expect to start seeing userspace/init
system (e.g. upstart) output. You have a correct console= line so I
can't think where this might be going.

Perhaps try booting with init=/bin/sh?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.