[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Can't clone static arm64 binary from https://github.com/susematz/qemu/tree/aarch64-1.6

On 06/25/2014 09:28 AM, Ian Campbell wrote:
> On Tue, 2014-06-24 at 13:57 -0400, John McDermott wrote:
>> Xen Developers,
>> Trying to build arm64 on x86_64 following the guidance on the wiki;
>> everything ok 'till I have to run qemu static for arm64. It fails
>> because there is no arm64 specific binary installed in Ubuntu 13.10,
>> even though the wiki procedure says it should work.
> Which wiki page?
>>  Not to worry; get the source and build it, I think.
>> However, I cannot clone the git repo for the source, no matter which system 
>> I clone from. I even tried it from a Mac and get the same "fatal repo not 
>> found" error.
>> The repo is 'https://github.com/susematz/qemu/tree/aarch64-1.6/' and I can 
>> see it in my browser just fine.
>> Is there an alternative source for this code?
> IIRC it's all in mainline qemu these days.

Last time I tried mainline QEMU (it was about a month ago), I was not
able to build the different package with an opensuse rootfs.

It was because of the threading issue. I don't think it has been fixed yet.

You can use the QEMU provided by Suse which work fine:

git clone -b aarch64-work https://github.com/openSUSE/qemu.git qemu-aarch64


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.