[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH RFC V4 2/5] xen: Optimize introspection access to guest state

  • To: Jan Beulich <JBeulich@xxxxxxxx>
  • From: Razvan Cojocaru <rcojocaru@xxxxxxxxxxxxxxx>
  • Date: Mon, 04 Aug 2014 17:43:40 +0300
  • Cc: kevin.tian@xxxxxxxxx, ian.campbell@xxxxxxxxxx, stefano.stabellini@xxxxxxxxxxxxx, andrew.cooper3@xxxxxxxxxx, eddie.dong@xxxxxxxxx, xen-devel@xxxxxxxxxxxxx, jun.nakajima@xxxxxxxxx, ian.jackson@xxxxxxxxxxxxx
  • Comment: DomainKeys? See http://domainkeys.sourceforge.net/
  • Delivery-date: Mon, 04 Aug 2014 14:43:52 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=default; d=bitdefender.com; b=rEZN2uYQX19TT4sTnBLpK48Wg843pnp14OkwdhXKaCTdfW+pGptNM/BD79yuZ9S1IBgpezVn/Eqgt5Gfd6Lk+rKaAOCD9rMsIVPHarOsUnt9hSpaqX49Rw5/RRNHxIdFc9KhSjFAXE23tn96kYp66lFDhrveWjHGDP3QpqMcqwf++568opO1+p7+Mmg1CXGgr8JxrXY+lDaKZQcEqaC1gAHmChF8smhM7MV9UDUbHt2iQWEb2B14RAwBxDbu2FzKZc1Zfur3j8lKFkVnXjc/9fug1QQi17A61eUD+7KFUxI/jT8Z3ii8gSDBfWmVeev2jXaGo4gwybY1EkpGQzXRkQ==; h=Received:Received:Received:Received:Message-ID:Date:From:User-Agent:MIME-Version:To:CC:Subject:References:In-Reply-To:Content-Type:Content-Transfer-Encoding:X-BitDefender-Scanner:X-BitDefender-Spam:X-BitDefender-SpamStamp:X-BitDefender-CF-Stamp;
  • List-id: Xen developer discussion <xen-devel.lists.xen.org>

On 08/04/2014 05:16 PM, Jan Beulich wrote:
>>>> On 04.08.14 at 13:30, <rcojocaru@xxxxxxxxxxxxxxx> wrote:
>> Changes since V3:
>>  - Changed the name of VCPU variables referring to the current
>>    VCPU to "curr".
>>  - Renamed "mem_event_regs" to "x86_mem_event_regs" to make it
>>    explicit.
> That's a step in the right direction, but perhaps not enough. I realize
> the whole header doesn't meet the requirements we nowadays put
> on public ones, but let's at least not make it worse. I.e. in the case
> at hand either out a xen_ prefix as the very first thing (making this
> structure's name not match anything else in that header) or as a
> compromise stay at least with the mem_event_ prefix, i.e. name it
> mem_event_regs_x86.
> Furthermore as typedef-ed name with out _t suffix is kind of
> unusual. I'm not sure if it was in the context of this series that
> someone suggested that the _t collides with the C standard. If
> that's really the case, and since you don't need a handle for the
> type, please just avoid the typedef (and drop the _st suffix from
> the structure tag at once).

Indeed, it has been suggested here:


I'll do the renaming.

Razvan Cojocaru

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.