[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH V3 4/6] xl: add pvusb commands

On 05/21/2015 12:58 PM, Juergen Gross wrote:
>>>> Yes, from a pedantic perspective, both will tell you on which devices
>>>> you can run "X-attach" without any extra arguments.  But from a
>>>> practical perspective, "xm usb-assignable-list" tells you something
>>>> practical about the state of devices on the whole system; and "xl
>>>> pci-assignable-list" tells you a technical quirk about devices are in a
>>>> half-way state between not being assigned and actually being assigned.
>>> I can't believe you are suggesting to use "a technical quirk" as a good
>>> example for future development. Just because a user interface isn't
>>> perfect shouldn't result in other interfaces to behave in the same
>>> imperfect way.
>> You seem to have missed in my tone that I think "xm usb-assignable-list"
>> behavior is more useful.  I said that "xm usb-assignable-list" gave you
>> practical information, and I said that "xl pci-assignable-list" gives
>> you about a technical quirk.  I also said that "pci-assignable" a state
>> half-way in between being assigned and not assigned, which I personally
>> think portrays it as rather clunky.
> I didn't want to offend you, sorry if you felt that way.

Misunderstandings happen -- I certainly misread what people write
sometimes.  It's mildly annoying but no harm done. :-)

>> I never claimed that we should make the new usb-*-list command mimic
>> pci-assignable-list.  What I'm responding to is your claim that they do
>> similar things, and so implying that it should be OK for them to have
>> similar names.  They do not do the similar things, and therefore they
>> must not have similar names.
>> So, as I said in the previous e-mail:
>> * I think that it would definitely be useful to have the "xm
>> usb-assignable-list" functionality.
>> * But we cannot give it the same name as the current "xl
>> pci-assignable-list" functionality, since they behave differently
>> * I think "assignable" is the best name for what "xm
>> usb-assignable-list" does; however,
>> * We have existing users to consider; I think choosing a different name
>> (like "xl usb-available-list") will have the lowest negative impact on
>> existing users.
> There might be existing users who know about "xm usb-assignable-list".

Yes -- unfortunately something has to give: either we confuse new users
with two names that sound similar but do something different, or we
confuse former xm users by renaming their function, or we confuse
current xl users by renaming their function.  There's badness to be had
whichever one we choose.  I think renaming the xm function is the least
bad of all the options.

> OTOH I don't care giving it another name, as long as the functionality
> is available.

OK -- what about "usb-available-list"?  Any objections / alternate
suggestions from anyone?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.