[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen on Arm Arndale Exynos5250

On Thu, 2015-11-05 at 12:59 -0600, ed sandberg wrote:

> My initial thought was that I needed to add a getty process on COM3, so
> that when I switched to Dom0 mode I could login.  This page seems to
> agree with me:
> http://wiki.xenproject.org/wiki/Xen_Serial_Console
> I tried to do so by creating a ttyS2.conf file under /etc/init/ that
> read as follows:
> start on stopped rc RUNLEVEL=[2345]
> stop on runlevel [!2345]
> respawn
> exec /sbin/getty -8 115200 ttyS2
> with that in place I was still not prompted to login but it had an
> effect because the serial connection would become unresponsive after a
> few minutes.

IIRC Linux's name for the console serial device on Arndale is ttySAC2,
so that is what you would want when booting natively (unless Linaro
have done some pretty extreme patching, which I wouldn't expect. I've
only used mainline on this platform).

If you are running as dom0 under Xen you want to have a getty on
"/dev/hvc0", the Xen PV console device, since the real UART will be
owned by Xen (due to the "dtuart=/serial@12C20000" which you will be
passing on Xen's command line).

I don't think any of the Arndale devices have multiple serial ports
exposed, but if they did then you could use separate ones for Xen's and
dom0's console, but the Linux name for dom0 would still be ttySAC<n>
not ttyS<n>.

When you created /etc/init/ttyS2.conf were there other similar files
around in that directory? I ask because that sounds like an upstart
path and I'm unsure if Saucy still uses upstart.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.