[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen on Arm Arndale Exynos5250

Thanks for the help Ian,

I tried using ttySAC2 in /etc/init/ttySAC2.conf but I still am not
prompted to login on the serial output.  I also tried creating
/etc/init/ttyhvc0.conf.  I think that is the correct place to start
getty from.  There are other similar files in that location and this page:


says that karmic and newer start console processes from /etc/init/
files.  I have also tried using /etc/inittab but that doesn't seem to

The linaro prebuilt image (no xen) boots and I am prompted to log in so
I tried comparing the boot process.  I found that the boot.txt file on
the boot partition had the following line:

setenv bootargs "console=tty0 console=ttySAC2,115200n8
root=UUID=bf05a5f4-06bf-4c99-8729-e20678372aea rootwait ro"

that makes me confident that you are correct about the console name
being ttySAC2.  I tried editing my environment variables to be more
similar to this as such:

# setenv xen_bootargs 'console=dtuart dtuart=/serial@12C20000 dom0_mem=512M'
# setenv dom0_bootargs 'console=hvc0 console=ttySAC2,115200n8
ignore_loglevel psci=enable clk_ignore_unused root=/dev/mmcblk1p3'

but that brings me to the same debug console with this instruction:

(XEN) *** Serial input -> DOM0 (type 'CTRL-a' three times to switch
input to Xen)

I can switch input to Xen and then I can get diagnostic info but that is
a far as I get.

On 11/06/2015 02:52 AM, Ian Campbell wrote:
> On Thu, 2015-11-05 at 12:59 -0600, ed sandberg wrote:
>> My initial thought was that I needed to add a getty process on COM3, so
>> that when I switched to Dom0 mode I could login.  This page seems to
>> agree with me:
>> http://wiki.xenproject.org/wiki/Xen_Serial_Console
>> I tried to do so by creating a ttyS2.conf file under /etc/init/ that
>> read as follows:
>> start on stopped rc RUNLEVEL=[2345]
>> stop on runlevel [!2345]
>> respawn
>> exec /sbin/getty -8 115200 ttyS2
>> with that in place I was still not prompted to login but it had an
>> effect because the serial connection would become unresponsive after a
>> few minutes.
> IIRC Linux's name for the console serial device on Arndale is ttySAC2,
> so that is what you would want when booting natively (unless Linaro
> have done some pretty extreme patching, which I wouldn't expect. I've
> only used mainline on this platform).
> If you are running as dom0 under Xen you want to have a getty on
> "/dev/hvc0", the Xen PV console device, since the real UART will be
> owned by Xen (due to the "dtuart=/serial@12C20000" which you will be
> passing on Xen's command line).
> I don't think any of the Arndale devices have multiple serial ports
> exposed, but if they did then you could use separate ones for Xen's and
> dom0's console, but the Linux name for dom0 would still be ttySAC<n>
> not ttyS<n>.
> When you created /etc/init/ttyS2.conf were there other similar files
> around in that directory? I ask because that sounds like an upstart
> path and I'm unsure if Saucy still uses upstart.
> Ian.
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxx
> http://lists.xen.org/xen-devel

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.