[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH V8 3/7] libxl: add pvusb API

On Tue, Nov 17, Chun Yan Liu wrote:

> I think libxl_device_usb doesn't need to be changed into libxl_device_usbdev? 

In case of vscsi the struct and functions names are odd. It was not
obvious which one belongs to a ctrl and which one belongs to a device.
In the meantime I have changed everything related to a scsi host, it
contains now 'vscsictrl'. The names related to devices will follow.

I suggest to do apply the same also to usb and make it clear what
belongs to a ctrl and what to a device. Havent checked your patch what
places that actually would be.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.